Dodge Nitro Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Do some custome work on the body mount some 35 m/t, touch up on paint, some custome bumber front and rear and a roof rack and plenty of lights this is the plan might take some time but follow me be patiant most stuff used will be custome Fabed to make it a one of a kind follow me and then build and help me out on questions when I'm stuck lol thanks I hope you injoy this
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
20190602_205933.jpg
20190602_205923.jpg
And here she is with the fenders and mud guards removed.....and the transmisio pan finally removed to replace solenoid by the way is my nitro the only one that had the exhaust in the way to remove transmission oil pan....couse it was hell....so yea I have to replace a trans solenoid and replace the starter but with the muffler in the way I'm thinking of just removing it all pluss I have some side pipes laying around what do yall think
 

·
Registered
Joined
·
5,223 Posts
here is a pic of a big wheel Nitro
 
  • Like
Reactions: Scar0

·
Registered
Joined
·
17 Posts
No way 35's will fit without serious body modifications. From what I've read on the subject and measurements done on my 07 R/T, the front fender shape and inner contours won't clear more than a 31 even with 2 or 3 inches of lift.
I think 35's would require a live axle conversion with a ridiculous amount of lift.
 

·
Registered
Joined
·
576 Posts
Should be an awesome fab-job! Look forward to your updates along the way!

Come on guys. Saying "It can't be done" is just silly. You can do anything with the proper application of time, money and high explosives! Go Rodolfo!
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #13 ·
Ok now to figure out if we need to send transmision to be rebuilt or just change out a solenoid....any one ever take off driving g all is good and smooth gears a shifting great and after warming up all the geers drop nitro wont move forward nor reverse wont rev past 2000 rpms when in geer but dos t move and whe. In park it revs great but wont move
 

Attachments

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Sounds like you pulled a sensor wire, causing limp mode.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #15 ·
Sounds like you pulled a sensor wire, causing limp mode.
But the nitro takes off well shifts great every time until it warms up I'm thinking the solenoid might be bad and malfunctions when it warms up...I'll be replacing the shift solenoid later today than the starter to move on the the lift build thanx forninput if u have any more keep on openings and input are what get things working
 

·
Registered
Joined
·
5,223 Posts
you should have an fault code registered when it happens ?.

check tranny fluid level is correct and the filter is clean, both low or high fluid levels will cause air to build up within the fluid.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #18 ·
Ok working on the lift now....any one have any advice on doing 4 inch spacer above strut for the front with 4 inch spacer on rear springs and longer shocks and moving mounting of strut arm and extending control arms.... I'll be removing fenders front and rear I aiming at fitting 35's all input is welcomed
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Grab your tape measure. You may have to move the cradle, or do a cradle drop to fit 35".
Custom A-arms both top and bottom.
Extend the trailing arms in the rear, Adjustable track bar or completely redesign the rear to an X type.
Longer brake lines both front and rear for sure. Cut /flare and add.
Have you checked out the Libby KK(08+) forums? There was a guy did a crazy build on a KK like what you are talking. It will give you some ideas.
 
1 - 20 of 20 Posts
Top