Dodge Nitro Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
67 Posts
Discussion Starter · #1 ·
Hi Guys
Heater not hot at all maybe a hint of difference between hot and cold on the dial but it certainly isn't warm!!, I have read it could be the blend door and seen pics of it on a lhd car but this rhd one must be different I cant see it anywhere. is it on the left or right??

Also coolant is confusing, is Pink glycol ok? it says not to use propylene glycol in the handbook but is Ethylene glycol based Antifreeze, incorporating the latest in Organic Acid Technology (OAT) with winter protection upto -36 C ok? as that seems to be about all you get here in the uk!

And,, on the diesel the coolant header tank is confusing me,,, the left side of it is empty, and the right side with the filler on it has a minimum mark but No maximum! how far do you fill it and how do you get coolant into the other side?? I'm thinking my level is low but it's above Min cold, could I have an air lock? I can't find any bleed screws etc I'm worried about over filling and blowing off a pipe,
hope you can help!
 

·
Registered
Joined
·
5,558 Posts
just a quick reply as i'm on my way to work,

coolant: 10mm above the minimum level when the engine is cold, lefthand side is always empty, and the pink coolant is the same as mine.

run your engine upto operating temperature, switch heater to max,in the engine bay at the bulkhead, check the 2 small hoses which run through the bulkhead to the heater core, they should both be hot and about the same temperature.
 
  • Like
Reactions: Scar0

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Any antifreeze that meets MS-9769 standards is OK to use.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #5 ·
just a quick reply as i'm on my way to work,

coolant: 10mm above the minimum level when the engine is cold, lefthand side is always empty, and the pink coolant is the same as mine.

run your engine upto operating temperature, switch heater to max,in the engine bay at the bulkhead, check the 2 small hoses which run through the bulkhead to the heater core, they should both be hot and about the same temperature.
I thought of feeling the hoses but the fuel filter is right on top of them, the hoses go down in the bay, where do they go to? thanks
 

·
Registered
Joined
·
5,558 Posts
Well done with the fix, the strange thing is the 2.8 doesn't suffer from the heater core getting blocked, like the petrol engines.
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Glad to hear a flush did the trick!
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #9 ·
Well done with the fix, the strange thing is the 2.8 doesn't suffer from the heater core getting blocked, like the petrol engines.
well this one did! there were what looked like small rocks in there!!! its still not mega hot so maybe the flap isn't opening fully. where is the actuator on the rhd diesel I have seen pics of the petrol one above the gas pedal but I cant see anything on the passanger side on mine and drivers side looks pretty packed up too, maybe i'm expecting it to be hotter than it should be !
 

·
Registered
Joined
·
5,558 Posts
did you flush the heater core in both directions ?.
do you mean actuator which lets the hot coolant flow through the heater core ?. if so the Nitro dosn't have one.
and your heater should blow hot like any other car.
 

·
Registered
Joined
·
67 Posts
Discussion Starter · #11 ·
yes I flushed both ways for a while, it took a lino pump to blow it free with low pressure before i put hose in!
No I know it has hot in it all the time i'm talking about the flap in the dash!
I think it's as hot as most but i just want to check its opening all the way if it's feasable to get to,

do you know where I can find the colour code I have looked in door jams and can't find it, dont want to start another thread!! is there a page for uk owners on this forum? I sam another one today the same colour and he said our colour is not inferno red but I am sure it is!! confused!!!
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
  • Like
Reactions: Nitrogen

·
Registered
Joined
·
67 Posts
Discussion Starter · #14 ·
Go here., https://www.mopar.com/en-us.html create an account (you will need your VIN, sign in.
Under, My Vehicle, Dashboard, Vehicle equipment, "Standard" button. it will have your paint color.
Then go here., http://www.nitroforumz.com/threads/quick-reference-guide.21221/
for the matching paint codes.

A dealer can also print out a build sheet with the original build info.
I did it but it comes up with
2007 DODGE NITRO SXT 4X4 RHD SPORT UTILITY 4-DR
there is no standard button in the dashboard just a warrenty and preferred dealer one
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
this is all i get
There is nothing on the right of the Pic you attached? That is where the "vehicle equipment" button is for my Nitro.
Maybe you need to add your VIN again? Not sure why it is not showing up...

EDIT: go here. http://www.dodge.com/webselfservice/dodge/index.html
Click on "Equipment Listing" on left side. In the center enter your VIN and click search button.

You can also request a build sheet VIA E-mail here,
http://www.dodge.com/webselfservice/dodge/emailpage.html
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Glad that worked. I was playing around in the site and accidentally deleted my Nitro from it. I added it back and now I see the same as what you do.
NON-OWNER! Arg... 2 calls to Dodge later and they still can't figure out how to add me back in as the owner of my Nitro! You should give them a call as well to get your Nitro listed with you as the owner.
1-800-423-6343
or 1-800-992-1997
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top