Dodge Nitro Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Ok. So. I installed an aftermarket touchscreen head unit. I purchased the fancy harness to make install easy. The problem is, when I turn off the Nitro, and lock the doors the unit loses power and wont come back on until I unplug/replug the harness from the unit. I've installed plenty of stereos before and this is a first for me. I'm lost. Does anyone know what could be causing this, thinking maybe it's a nitro thing?
 

·
Registered
Joined
·
61 Posts
It could be a number of things. Is it a brand new HU? If it is older, is it compatable with the Nitro's Canbus. It is also possible the the HU is damaged or defective. First thing to try doing is a radio reset. Disconnect the negative batter cable for at least 30 minutes. This should reset everything.
 

·
Registered
Joined
·
5 Posts
Your problem may be in the aftermarket harness. It is recommended to use a dash Frame ground, separate from the OEM harness ground. Most of the Dodge stereos used a radio case ground and since the OEM hands free, temps and all other notification (canbus) systems went through the OEM Headunit, you really need an aftermarket system compatible with allowing all or most crucial systems to be seen and reported. Maestro and PCI are 2 great stereo adapter manufacturers for aftermarket installations.
Otherwise, I’d suggest checking that your accessory fuse hasn’t blown or that the aftermarket harness is actually making proper connection with the OEM harness accessory wire pin. Sometimes on rare occasion, the aftermarket radio harness is wrong on power and accessory leads!
Good luck!
 
1 - 3 of 3 Posts
Top