Dodge Nitro Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi! Searched a bit and didn't see this one.

Today, I got in, and noticed the radio was silent. tried tuning to stations up and down the dial to no avail. Volume turned way up. No scratching sounds or any other noises come out of any speaker. Dead silence. However Sirius XM still plays perfectly fine - sounds great.

Im baffled. Don't know the first place to troubleshoot. Ideas?

Only other sort of electrical issue I can think to describe is that my driver's side heated seat is... Intermittent at best. It works sometimes but sometimes just won't, you can click the button on and the light will just turn off after 2 seconds, oddly confusing there too.

Thanks for any help/ideas!
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,305 Posts
You can try a radio reset.
Most resets only take 10 minutes with the Neg(-) battery cable disconnected. But the magic # for a radio reset seems to be 30+ minutes.

The other prob with the heat seat. Sounds like a short or bad connection.
While you have the battery disconnected for the radio, look at the wires under the seat for the heater.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Sounds good to me. Hell, I'll leave the negative disconnected overnight tonight!
Any links you can provide in the meantime for what I'm looking for under the seat? I'm not sure how to test anything because like I said, the seat heater will literally work sometimes and other times just turn off by itself lol
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
Hey scar. Quick update. Did the radio/amp fuse pull + battery neg disconnect for the last hour or hour and a half or so. Reconnected everything, can verify the radio totally reset. Sound came through for the FM station after I turned on the radio again for about 5 seconds then cut out. XM is still working just fine all channels.

Any idea what this could now indicate??

Thank you so much for any help.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,305 Posts
HU are not my best area. Hopefully the other thread you posted in some one will chime in.
It could be software, or it could be something internal getting heat soaked. Hard to say.
 
1 - 5 of 5 Posts
Top