Dodge Nitro Forum banner
1 - 7 of 7 Posts

·
Registered
07’ SLT 4x4 Lifted, 3.7 auto
Joined
·
820 Posts
Discussion Starter · #1 ·
Anyone had consistent issues with the axle shaft bushings up front? Just had to replace driver side……I’ve replaced passenger side few years back but it’s developing play again! At least that’s what the play appears to be from. It Cleared up the driver side noise. Maybe just repercussions of the lift….and off-roading ?
 

·
Registered
07’ SLT 4x4 Lifted, 3.7 auto
Joined
·
820 Posts
Discussion Starter · #3 ·
Yes. The damned plastic bushing…..I replaced passenger side when I lifted it bc upon removing the CV it pulled the intermediate with it. Just replaced it bc I was there. With mopar parts. I did driver side other day bc I heard rattling. After a couple parts( cv, tie rod end, strut) finally found it to be that bushing. My issue is that I’m starting to get the same play and rattle from passenger side again. It could have been doing it all along I just hear it now that drivers side is fixed. Just curious…… I assume it’s the angles from the lift on top of bottoming out while stuck and the wheels hanging while off-roading.

why is this thing cheap plastic.
I haven’t removed pass side yet to confirm but it seems that’s def it. Unless it’s the inner bushing I never did.

Do we still have a promo on mopar online? I’ve been paying shipping bc the old one no longer worked. (n)
 

·
Registered
Joined
·
5,777 Posts
it's quite common for this bushing to wear out, but not within a few years, most likely because of the angle when you are off roading, mine has a little bit of movement after 70k miles,
if you contact Benny at "Moparonlineparts" pretty sure he would still give a forumz discount,
 
  • Like
Reactions: JPthekid

·
Registered
07’ SLT 4x4 Lifted, 3.7 auto
Joined
·
820 Posts
Discussion Starter · #6 ·
I couldn’t remember if there was an inner one on the passenger side as well. Thanks though. I just got some in and am going to do the pass side again. Hopefully they’ll last awhile. Weird how both mine have play at same time though. I did get stuck pretty good and had front axles hanging….prob did it
 
  • Like
Reactions: Nitrogen

·
Registered
Joined
·
5,777 Posts
have you ever replaced your rear axle output shaft seal, mine is leaking, i tried to undo the large nut but it would not budge so i have left it for now,
 
1 - 7 of 7 Posts
Top