Dodge Nitro Forum banner

1 - 9 of 9 Posts

·
Registered
2010 nitro sxt black
Joined
·
8 Posts
Discussion Starter · #1 ·
Any help with figuring out why my drivers side blinker and fog light won't work would be appreciated! I read in an old post about a faulty ground. Could someone please elaborate a bit for me. Not a lot of expert with these things
 

·
Registered
2010 nitro sxt black
Joined
·
8 Posts
Discussion Starter · #2 ·
drivers side blinker marker and fog all out. New ground no help. What next?
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Silly but I have to ask. Are the bulbs good?
When did this start? Anything we need to know happened before this occurred?
 
  • Like
Reactions: Nitrogen

·
Registered
2010 nitro sxt black
Joined
·
8 Posts
Discussion Starter · #4 ·
When I b ought it in Dec I pointed out to the dealer. They had me take it to a shop for repaire after I. Ought it. The guy at the shop told me he fixed it and it worked. I didn't make it the 35 miles home b4 it stopped again. Since then my marker light has went out and then my fog. All brand new bulbs eventhough none have been blown. Real funny thing is when I locked my doors with my fob. The damn blinker blinker blinks. The dealer told me to take it back to the same guy and he said he doesn't do much electrical stuff. I really like my Nitro and would like to get these things taken care of so I can focus more on aftermarket upgrades.
 

·
Registered
Joined
·
5,164 Posts
the lights and ignition must be in the Off position, then for testing purposes, connect a ground wire direct from the Negative battery terminal to the lights, then switch the lights on,
several members have found some bulb connector sockets have dirty contacts,
most of the electrics are computer controlled, maybe try a computer reset: disconnect Negative battery terminal for 10 minutes then reconnect, if the computer senses a fault it will cut the power to the specific circuit, (worth a try its free),
 
  • Like
Reactions: Scar0

·
Registered
2010 nitro sxt black
Joined
·
8 Posts
Discussion Starter · #6 ·
I have done tried the reset and ran new dedicated grounds for all 3 lights that are out. My test light shows power at the plug for the blinker. Not sure how much I got aggravated and quit
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
3/4 the way there. Next test inside the socket for power.
While in there inspect the bulb contact points in the socket.
 
  • Like
Reactions: Nitrogen

·
Registered
2010 nitro sxt black
Joined
·
8 Posts
Discussion Starter · #8 ·
Update on my electrical issues with my lights. After pulling most of what's left of my hair out working on this I took a moment and stepped back. When I ran the new ground for each light I used quick connects. When I unwrapped them retracing my steps I found that I had used the blue ones that are too large to properly pierce the jacket on the wire. I removed and replaced them with red ones that are for 16 gauge wire and BAM lighting issue fixed. Not a moment too soon I might add!! I can't afford to loose any more hair.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Gota like a happy ending!
 
  • Like
Reactions: Nitrogen
1 - 9 of 9 Posts
Top