Dodge Nitro Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
69 Posts
Discussion Starter · #1 ·
If i start taking a turn a little too fast I will apply the brakes and then a shaking of my brake pedal occurs. This only started after I threw on a daystar spacer lift kit and 265/65R17 wheels and tires. Is this just the ABS kicking in? Has anyone else had this problem?

Also has anyone needed to flash the PCM after putting on bigger wheels and tires at all?
 

·
Registered
Joined
·
2,091 Posts
Sounds strange. If the abs is kicking in should you not get some other indication?
Is there a fuse for just the ABS?
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Yep! The lift messed up your steering angle sensor.
Mine did this also.
For me it was a right hand slightly bumpy turn that would kick off the ABS.
I had the dealer calibrate the steering angle sensor after my alignment. No issues since.

The Nitro only has 3 preset tire sizes that a dealer can be program into the computer. Those are the 3 OEM tire sizes. The 20" tire is the largest of the three at 29.65” diameter.
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Yes, and no.
You will have to have it aligned and then have the dealer calibrate the sensor.
If the alignment shop does a good job, the calibration should work. If it is not aligned well, meaning they take all the toe out of one side, then even after the calibration you may still occasionally get the ABS activation on turns.
Even with an alignment, and calibration it may still kick in.
Part of the problem with lifting is the OEM upper A-arm is not long enough for a proper alignment to be done. Even with my new A-arms my rig was barely in specs.
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
I tried to re-learn mine. It did not work. So I had the dealer do it. So far so good.
 

·
Registered
Joined
·
92 Posts
I think I just brake not too much.... In general. A lot of highway, no urban centers. My braking System is permanently cold and slightly underpressured. I basically often need to brake once every xx minutes... Not a Real problem, just a feeling
 

·
Registered
Joined
·
92 Posts
I think I just brake not too much.... In general. A lot of highway, no urban centers. My braking System is permanently cold and slightly underpressured. I basically often need to brake once every xx minutes... Not a Real problem, just a feeling
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top