Dodge Nitro Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey everyone,
About 4 days about I ran to a store and parked my car. Nothing alarming and everything seemed to be running great. I come out of the store and my car won’t start. I turn the key all the way and the car violently shakes and won’t start. It sounds like it’s trying to turn over but it’s not the traditional clicking. It’s louder. All the lights are the dash lit up as I tried to start it. I was able to turn the key one click and the Windows, radio, and lights all work. I had it towed to a shop. They looked at it 3 days later and the car started fine. They couldn’t replicate the problem so no way to tell what it was. But Does anyone know what the issue could have been?
Makes me nervous to drive it long distances without knowing when or where it could act up again.
 

·
Registered
Joined
·
5,343 Posts
from your description 99.9% sure its the battery leads loose or dirty, could be at the battery, chassis, starter or TIPM end, basicly follow all the battery leads end to end and make sure they are tight and clean, could also be a corroded Ground lead under the battery tray (quite common) or simply a battery fault,
 

·
Registered
2007 R/T
Joined
·
174 Posts
So it turned over, cranks and cranks, but no fire?

What do you have? Diesel? 3.7L? 4.0L?

Could be a fuel pump relay on the fritz or fuel pump or ???
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
So it turned over, cranks and cranks, but no fire?

What do you have? Diesel? 3.7L? 4.0L?

Could be a fuel pump relay on the fritz or fuel pump or ???
I have a 3.7L nitro heat. That was my thoughts exactly but they said there is no way to test unless the problem is actively happening
 

·
Registered
2007 R/T
Joined
·
174 Posts
You can bypass the relay and if it happens again, most likely the fuel pump:


 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
So it turned over, cranks and cranks, but no fire?
It was cranking over and over without starting and it seemed really rough. But the shop got it to start just fine. They still have the car. They have been driving it around to try to replicate the problem but no luck. Is there a way to test the relay and pump even though the car is starting up fine for now or do I just have to wait until it craps out again?
 

·
Registered
2007 R/T
Joined
·
174 Posts

buy test wire from:

 

·
Registered
Joined
·
2 Posts
Hey everyone,
About 4 days about I ran to a store and parked my car. Nothing alarming and everything seemed to be running great. I come out of the store and my car won’t start. I turn the key all the way and the car violently shakes and won’t start. It sounds like it’s trying to turn over but it’s not the traditional clicking. It’s louder. All the lights are the dash lit up as I tried to start it. I was able to turn the key one click and the Windows, radio, and lights all work. I had it towed to a shop. They looked at it 3 days later and the car started fine. They couldn’t replicate the problem so no way to tell what it was. But Does anyone know what the issue could have been?
Makes me nervous to drive it long distances without knowing when or where it could act up again.
Have the same issue, fuel pump is going bad. However if it does it again cycle the key a few times and wait for the dinging to stop and it should fire right up.
 

·
Registered
Joined
·
3 Posts
Hey everyone,
About 4 days about I ran to a store and parked my car. Nothing alarming and everything seemed to be running great. I come out of the store and my car won’t start. I turn the key all the way and the car violently shakes and won’t start. It sounds like it’s trying to turn over but it’s not the traditional clicking. It’s louder. All the lights are the dash lit up as I tried to start it. I was able to turn the key one click and the Windows, radio, and lights all work. I had it towed to a shop. They looked at it 3 days later and the car started fine. They couldn’t replicate the problem so no way to tell what it was. But Does anyone know what the issue could have been?
Makes me nervous to drive it long distances without knowing when or where it could act up again.
I had the same issue myself, starts right up then next time it would rattle and sounds like it wanted to shut off. My Nitro had the original spark plugs from factory, I had 98K on those plugs, I replace the plugs and wire harness and it took care of the problem. Hope it works for you
 

·
Registered
2007 R/T
Joined
·
174 Posts
I had the same issue myself, starts right up then next time it would rattle and sounds like it wanted to shut off. My Nitro had the original spark plugs from factory, I had 98K on those plugs, I replace the plugs and wire harness and it took care of the problem.
Wire harness?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #12 ·
Update:
Took the nitro to the dealer on Friday and they found a star case for the problem and did some hard resets on the TIPM and performed a circuit bypass for the fuel pump relay. So far no issues with starting. Hope that fixes it.
However, I noticed today that my cruise control now does not work. It was working fine before taking it in. When I’m driving, doesn’t matter the speed, upon pressing the cruise control button, nothing happens. But when I’m stopped and idling, the cruise control button will turn on if pressed. Anyone have any ideas what the issue could be? Could it be something that the dealer did when they did the TIPM resets?
 
1 - 12 of 12 Posts
Top