Dodge Nitro Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello everyone, recently I've been having issues with my beloved nitro. I'll be very nice and short about it, basically when I attempt to start it, it just keeps on cranking for about a minute, sometimes 2 minutes before starting. When it starts it works like usual, but I've restrained myself from driving it mostly out of fear of not messing something more up due to the long cranks, like burning out the starter (I've heard that's possible). I'd also like to add that I've had the car one year exactly. Now for some things that I've noticed about it:
When I'd try and crank it I'd always let the fuel pump do its thing, and I still hear it pumping for about 10-15 seconds (it's always taken thing long, I know it isn't ideal), I have also tried the turn key/off/turn/off/wait/turn etc trick, nothing happens, still cranking for a minute and more. That's about all I know about it at the moment, my dad has reported that it had a hard time shifting gears yesterday, or didnt shift gears at all but I have never experienced this so it might not be true, but if there's some correlation maybe it'll prove to be helpful that I wrote it down as well. Thank you guys for looking into this, hope you'll manage to help me out :)
 

·
Registered
2007 R/T
Joined
·
174 Posts
Sounds like injector issues. Either dirty or worn out.

There should be places near you that test/clean/test your originals.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
Hard time shifting...manual or automatic?
It's an automatic, but like I've said I never experienced this issue. He described it as he's giving it gas but couldnt hear gears shift. And after that he turned it off and back on (took him a minute again) and it was working as normal, so not sure what happened there.
 

·
Registered
Joined
·
5,343 Posts
here is a thread with some info by Jan,
 

·
Registered
Joined
·
318 Posts
Whats your milage? If it is over 200 000 km I'm sure it's bad injector(s). Is engine oil level OK? Too much oil is a symptom of leaking injector nozzels (fuel in oil).
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Whats your milage? If it is over 200 000 km I'm sure it's bad injector(s). Is engine oil level OK? Too much oil is a symptom of leaking injector nozzels (fuel in oil).
It's just around 150k, engine oil is good I've had it changed about 10k km before this happened, engine is dry as sand, like it's new pretty much.
 

·
Registered
Joined
·
5,343 Posts
have you checked the glow plugs ?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
have you checked the glow plugs ?
To be fair two of them are shot, but I had the pair switched out when doing my little tests and it didn't stop the car for cranking so long. Had a friend "mechanic" look into it this morning, he's saying it could be bad fuel injectors or the pump itself (apparently if it's working 10-15 seconds that's very slow for a pump) but still no definite answer.
 

·
Registered
Joined
·
5,343 Posts
my pump also pumps for 10-15, just in case you don't know the glow plugs are not 12vdc
 

·
Registered
2007 R/T
Joined
·
174 Posts
I'd start another thread regarding transmission issues.

You may be low on fluid or just old, cruddy fluid.
 

·
Registered
Joined
·
68 Posts
This extended crank issue has never been fully resolved in hundreds of posts. Reason being, it is so random that when someone thinks that they have resolved it it can return a year later. It does not throw any kind of code, and it is hard to take it to a mechanic when it is not doing it all the time. I have gone a year without it happening, and then it recurs. Nitro runs perfectly. Every person that has had this issue describes it the exact same way.
 

·
Registered
Joined
·
5,343 Posts
This extended crank issue has never been fully resolved in hundreds of posts. Reason being, it is so random that when someone thinks that they have resolved it it can return a year later. It does not throw any kind of code, and it is hard to take it to a mechanic when it is not doing it all the time. I have gone a year without it happening, and then it recurs. Nitro runs perfectly. Every person that has had this issue describes it the exact same way.
Nitrooutro is asking for the 2.8crd engine nitro which "normaly" does not have the no start issue, but they do have issues with long cranking before starting,

Andrea i found a youtube video which could help you, i will post it in your original thread (if i can find it),
 

·
Registered
Joined
·
68 Posts
Nitrooutro is asking for the 2.8crd engine nitro which "normaly" does not have the no start issue, but they do have issues with long cranking before starting,

Andrea i found a youtube video which could help you, i will post it in your original thread (if i can find it),
Thanks, i don't see the video post. Let me know if you to found it...
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #16 ·
Just a little update, had it taken to more mechanics. Nobody still knowns what the issue is, it's just guessing between it being one of the fuel pumps (so my only choice is to buy them, have them changed and see if it fixes the issue). Since I'm kind of low on cash at the moment I'm gonna let it stay like this until the next week. I have tried the key on and off thing again, waited for it to do its thing 6 times and the same issue happened so I'll be getting the pump in the engine first and rule that one out of the equation. Wish me luck guys and gals :D
 

·
Registered
Joined
·
68 Posts
Just a little update, had it taken to more mechanics. Nobody still knowns what the issue is, it's just guessing between it being one of the fuel pumps (so my only choice is to buy them, have them changed and see if it fixes the issue). Since I'm kind of low on cash at the moment I'm gonna let it stay like this until the next week. I have tried the key on and off thing again, waited for it to do its thing 6 times and the same issue happened so I'll be getting the pump in the engine first and rule that one out of the equation. Wish me luck guys and gals :D
This is the most frustrating issue I have ever had with a vehicle. Please, update and, if you can, message me directly, I don't know if that is possible in this forum, please do. This has been going on for years. And it may go a year without doing it, and then it may do it every few days then stop. My issue is it scares the heck out of me when it does it. I travel by myself, I am female, and I'm certainly not mechanically inclined. I am smart about researching things though. And I have looked at many responses here, and the thing about it is no one ever really has come up with a resolution that was long-term. They do something and either don't come back and update or it happens again 6 months later. I have taken it to multiple mechanics, at one shop they changed the cam sensor, after they had attempted to duplicate it over 50 times and it never did it. They just decided that they would change the cam sensor! Last weekend, I was out of town by myself and was leaving the hotel early in the morning and it did it. It started after I did the key dance, and who really knows that the key dance makes the difference! I am not going to sink a bunch of money in this, or even consider doing that until it is completely broke down and will not start. There has never been a code recorded for this. As a side no, this nitro runs perfectly. It has been recently tuned up which technically wasn't even necessary at the time. I have no issues with it it has about 185,000 mi on it. There is no rhyme or reason to it being a cold start or warm start. The temperature outside has nothing to do with it, there is no one commonality that I can find to determine when it is going to occur. Okay, sorry that was long, but I just wanted to express my experience and be up front about it!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #18 ·
This is the most frustrating issue I have ever had with a vehicle. Please, update and, if you can, message me directly, I don't know if that is possible in this forum, please do. This has been going on for years. And it may go a year without doing it, and then it may do it every few days then stop. My issue is it scares the heck out of me when it does it. I travel by myself, I am female, and I'm certainly not mechanically inclined. I am smart about researching things though. And I have looked at many responses here, and the thing about it is no one ever really has come up with a resolution that was long-term. They do something and either don't come back and update or it happens again 6 months later. I have taken it to multiple mechanics, at one shop they changed the cam sensor, after they had attempted to duplicate it over 50 times and it never did it. They just decided that they would change the cam sensor! Last weekend, I was out of town by myself and was leaving the hotel early in the morning and it did it. It started after I did the key dance, and who really knows that the key dance makes the difference! I am not going to sink a bunch of money in this, or even consider doing that until it is completely broke down and will not start. There has never been a code recorded for this. As a side no, this nitro runs perfectly. It has been recently tuned up which technically wasn't even necessary at the time. I have no issues with it it has about 185,000 mi on it. There is no rhyme or reason to it being a cold start or warm start. The temperature outside has nothing to do with it, there is no one commonality that I can find to determine when it is going to occur. Okay, sorry that was long, but I just wanted to express my experience and be up front about it!
Yeah it definitely seems to be a hard fix with these cars, apparently some times it can be an issue with a fuse box - the M25 fuse to be exact, I'm not sure if that will work for you but it seems to have fixed quite a few nitros in my area with the same issue . Here's a video on how it's done, may be worth a shot.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #19 ·
This is the most frustrating issue I have ever had with a vehicle. Please, update and, if you can, message me directly, I don't know if that is possible in this forum, please do. This has been going on for years. And it may go a year without doing it, and then it may do it every few days then stop. My issue is it scares the heck out of me when it does it. I travel by myself, I am female, and I'm certainly not mechanically inclined. I am smart about researching things though. And I have looked at many responses here, and the thing about it is no one ever really has come up with a resolution that was long-term. They do something and either don't come back and update or it happens again 6 months later. I have taken it to multiple mechanics, at one shop they changed the cam sensor, after they had attempted to duplicate it over 50 times and it never did it. They just decided that they would change the cam sensor! Last weekend, I was out of town by myself and was leaving the hotel early in the morning and it did it. It started after I did the key dance, and who really knows that the key dance makes the difference! I am not going to sink a bunch of money in this, or even consider doing that until it is completely broke down and will not start. There has never been a code recorded for this. As a side no, this nitro runs perfectly. It has been recently tuned up which technically wasn't even necessary at the time. I have no issues with it it has about 185,000 mi on it. There is no rhyme or reason to it being a cold start or warm start. The temperature outside has nothing to do with it, there is no one commonality that I can find to determine when it is going to occur. Okay, sorry that was long, but I just wanted to express my experience and be up front about it!
Also it working after doing the key dance, that points to it being the fuel pump itself I believe. How long does the fuel pump hum for you when you put the key in the second position?
 

·
Registered
Joined
·
68 Posts
Maybe 5 seconds of humming. So, why no codes? Can the fuel pump be checked to see if it is faulty. I key dance 3 times in a row...
 
1 - 20 of 23 Posts
Top