Dodge Nitro Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello i have a 3.7 and when i go to turn it on it struggles a lot to turn on and i noticed 2 off my coils where down so i bought them new and still they wont run the two cylinders
 

·
Khaki Nitro Nut
Joined
·
29,837 Posts
What year, how many miles, when did it start, what have you tried?
 

·
Registered
Joined
·
622 Posts
Compression test and work my way back. At least on the 2 that won’t do right.... in theory a couple more or all of them to make sure they are all close... then compare to the 2 not firing. Make sure injectors ok.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Compression test and work my way back. At least on the 2 that won’t do right.... in theory a couple more or all of them to make sure they are all close... then compare to the 2 not firing. Make sure injectors ok.
I cleaned out the injector crompression is great and still wont start it only cranks
 

·
Registered
Joined
·
622 Posts
then I’d check to be sure my coils had voltage and my plugs were actually sparking if compression is good. After that I’d see what else other members mention lol beyond my scope if all that is well. Try to test the plugs in a dark room to be sure they r sparking
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
then I’d check to be sure my coils had voltage and my plugs were actually sparking if compression is good. After that I’d see what else other members mention lol beyond my scope if all that is well. Try to test the plugs in a dark room to be sure they r sparking
Thanks ill have to check them coils very good or replace them
 

·
Khaki Nitro Nut
Joined
·
29,837 Posts
In the TIPM is an ASD (K10) relay and related fuses(M19- M21). Make sure those are OK.
If you haven't done so, Disconnect the Neg(-) battery cable for 10 minutes to do a reset.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
then I’d check to be sure my coils had voltage and my plugs were actually sparking if compression is good. After that I’d see what else other members mention lol beyond my scope if all that is well. Try to test the plugs in a dark room to be sure they r sparking
So i check the coils and they do have voltage and dont kniw where to go from here now it wont start but only crank and will stall out now
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
In the TIPM is an ASD (K10) relay and related fuses(M19- M21). Make sure those are OK.
If you haven't done so, Disconnect the Neg(-) battery cable for 10 minutes to do a reset.
Will do but it seems like to much gas is flowing thur
 

·
Khaki Nitro Nut
Joined
·
29,837 Posts
If you have spark then the ESD relay, and related fuses are good.
 
1 - 14 of 14 Posts
Top