Dodge Nitro Forum banner

What problems have you experienced with your Dodge Nitro?

1 - 20 of 30 Posts

· Registered
Joined
·
1,254 Posts
It's been about 6 weeks since the engine stall while driving. Service Dept. replaced TIPM. No other issues since then.

It's been about twice as long for the stalling at idle.
 

· Registered
Joined
·
74 Posts
Nitro's going to the shop on Monday for them to check out this shudder at 35-40. Have a little over 2000 miles on it and had a really rough episode on the way back from Pullman last weekend. Hopefully whatever they do won't make it worse....
 

· Registered
Joined
·
148 Posts
Hadn't had any problems until today. Now at about 3100 miles, I'm having very hard shifts if I accelerate continuously at a fairly "brisk" pace (not wide open) up to around 70 MPH -- for example, starting from a stop and merging into highway traffic on a short ramp.

I had a couple of hard shifts very early on but I ignored them assuming the transmission was still doing it's learning. Everything has been very smooth until today's little episodes on the highway.

It feels just like a slipping clutch would in a standard tranny. This is a 4L R/T 4x4.
 

· Registered
Joined
·
148 Posts
The problem with the poll is, if you vote too early, you can't change your vote later on if you do have trouble. I went 3100 miles without problems. In the earlier poll I did vote no trouble. Now I'm having hard shifts.

No good way to address this problem that I'm aware of. (I normally use phpBB, but as I recall vBulletin doesn't have a way to allow people to change their vote, unless you can find a mod somewhere?)

Just a thought.
 

· Registered
Joined
·
413 Posts
Had her 1 month now

Have zero problems...........actually i have on problem, looks like they incorrectly zipped the boot on the emergency brake handle and a portion of the center of the zipper portion (on the bottom side of the boot) came open.
No biggie........when i get a chance i will try and see if i can unzip the boot and rezip it. If that doesnt work then i will take her back to get it fixed
 

· Registered
Joined
·
30 Posts
The car has 7k miles on it and I have had shifting issues...it has stalled in a tight parking spot..it has stalled going 45 mph in a straight line....it has a bad shutter from 1 to 2.

The more I drive it the more noisey it gets ..road noise ..engine noise.
Not a very well built car at all.

I'm starting to not like this car.
 

· Dodge Nitro Forum
Joined
·
9,544 Posts
Issues

I bought my Nitro back in October In the shop for door lock problems then shifting problems then my steering wheel came lose just a little over 3000 miles on now and seems to be running ok now! have an issue with the molding on windshield on drivers side just not fitting in place like passengers side anyone else se this on there vehicle?
 

· Registered
Joined
·
257 Posts
Mine is going in on Thursday for that transmission thing. I backed out of my driveway this afternoon and when I went from R to Drive, it took like 2 seconds then jumped into Drive... and it did a nice jerk... While driving this afternoon it felt like it wanted to downshift into the passing gear... just spazzed for a few minutes. After I changed from 75 to 85 MPH it went away... but I sure dont need another speeding ticket... Husband might take my car away....

The other thing is the ESP light comes on when I back down a steeper enbankment then my driveway... Done that twice now
 

· Registered
Joined
·
20 Posts
The other thing is the ESP light comes on when I back down a steeper enbankment then my driveway... Done that twice now[/quote]


I voted no problems, but come to think of it I did have this issue with the ESP light. It happened a couple times, but hasn't happened again in a few months. Over 9,000 miles now and no engine problems
 

· Registered
Joined
·
10 Posts
My Nitro has about 15,000. MI. on it. 3.7L, auto trans.. Had the hard shifting right from day one. It's also loud. It's more noticeable when passing on the highway and increasing speed on an entrance ramp to the highway. I figured because it was new, it needed time to break in and settle. At 10,000 MI. it went back to the dealer. It's still the same. It's not enough of a problem that it bothers me so as others, I'll wait for Dodge to issue a PSB (when they figure it out).
 
1 - 20 of 30 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top