Dodge Nitro Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 07 dodge nitro R/T that I love. The motor spun a crank bearing and damaged the crank beyond repair. I purchased a motor and trans from a wrecked 08 nitro. I used the wiring harness with the 08 in my 07. The engine runs good but it will only idle no accelaration and electric symbol is on, f symbol on, ESP symbol on and skid symbol on. Has anyone had this problem. What do I need to do to fix the problem. Hope someone has run into this problem.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,538 Posts
We have not had a lot of engine swaps with the 4.0. But if I were to guess, I'd say the 08 harness was bad.
But what harness exactly did you use from the 08?
 
  • Like
Reactions: Nitrogen

·
Registered
Joined
·
3 Posts
Discussion Starter #3
We used the motor and the transmission that was in the 08. The harness had wires in it that went to the computer in fact the wires had 3 plugs for the computer. All the wire plugs on the harness fit just like the 07. We though that we could save some time if we used the 08 4.0 nitro wiring since they were the same body just a year newer. The motor run good but no throttle trans, had hard shift when I put it in gear, had a skid turn on light, trans light on and electrical light flashing. We took the 07 harness and changed them out and now every thing works great. I guess some of the wiring made a change from 07 to 08. We didn`t change any sensors or anything but the harness. hope this will help someone in the future.
 

·
Registered
Joined
·
5,120 Posts
Well done dodge nitro man, i thought any engine swap in a Nitro would run into all kinds of computer programming problems.
 
  • Like
Reactions: Scar0

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,538 Posts
Good to hear thing are working again. Glad to hear it was just the harness.
 

·
Registered
Joined
·
11 Posts
We used the motor and the transmission that was in the 08. The harness had wires in it that went to the computer in fact the wires had 3 plugs for the computer. All the wire plugs on the harness fit just like the 07. We though that we could save some time if we used the 08 4.0 nitro wiring since they were the same body just a year newer. The motor run good but no throttle trans, had hard shift when I put it in gear, had a skid turn on light, trans light on and electrical light flashing. We took the 07 harness and changed them out and now every thing works great. I guess some of the wiring made a change from 07 to 08. We didn`t change any sensors or anything but the harness. hope this will help someone in the future.
The 07 as I understand it doesn’t have a CAN Bus, the 08 does. So the harness, computer and other modules are slightly different.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,538 Posts
The 07 as I understand it doesn’t have a CAN Bus, the 08 does. So the harness, computer and other modules are slightly different.
The 07 does have a CAN BUS. As do all the Nitro's. 07 was the first year the Dodge CAN went to high speed. In 10~11 some things with the CAN changed a little, but 99% is still the same.
 
  • Like
Reactions: Nitrogen
1 - 8 of 8 Posts
Top