Dodge Nitro Forum banner
1 - 20 of 20 Posts

· Registered
Joined
·
172 Posts
Discussion Starter · #1 ·
Every now and then I will start up my Nitro and my ESP lights will be on. The ESP will also be off. Most of the time, it goes away after I get going, but sometimes it doesnt. I have not had the chance to get it into a dealer yet, and I dont have any other means of transportation otherwise. Has anyone else had the same thing and if you have, what did you do to get rid of it once and for all?
 

· Registered
Joined
·
379 Posts
never had that problem either sry about tho lad!!!:))
 

· Registered
Joined
·
254 Posts
Every now and then I will start up my Nitro and my ESP lights will be on. The ESP will also be off. Most of the time, it goes away after I get going, but sometimes it doesnt. I have not had the chance to get it into a dealer yet, and I dont have any other means of transportation otherwise. Has anyone else had the same thing and if you have, what did you do to get rid of it once and for all?

hey vinny, i have just over 35,000 miles on my nitro and today for some reason while driving approx. 55 mph on a smooth road, nice day, no water, no major bumps in the road because they just resurfaced it, my esp/bas(electronic stability program/brake assist system) light came on and will not go off. also the traction control light came on at the same time.

i made an appointment for next tuesday, 7 am to get them to fix the problem. i'll let you know what i find out. frustrating though, vehicle runs fine but the little error lights up and dings!!!:mad:

mcnabb (kaleos) in louisiana..........
 

· Registered
Joined
·
172 Posts
Discussion Starter · #8 ·
So I am not the oy one. Please let me know what oyu find out. Thanks


hey vinny, i have just over 35,000 miles on my nitro and today for some reason while driving approx. 55 mph on a smooth road, nice day, no water, no major bumps in the road because they just resurfaced it, my esp/bas(electronic stability program/brake assist system) light came on and will not go off. also the traction control light came on at the same time.

i made an appointment for next tuesday, 7 am to get them to fix the problem. i'll let you know what i find out. frustrating though, vehicle runs fine but the little error lights up and dings!!!:mad:

mcnabb (kaleos) in louisiana..........
 

· Registered
Joined
·
254 Posts
So I am not the oy one. Please let me know what oyu find out. Thanks
hey vinny, today while driving my nitro, i went about 8 miles and the light bas went off and so far has not come back on. my nitro has had more glitches in it than the tremendous amount of hair on a grizzly bear!!!:chuckle::mad::i_rolleyes: anyway besides this litte item coming on by itself, i also have the tire pressure monitoring system light come on when it wants and goes back to normal whenever it chooses. frustrating little things aren't they?

mcnabb (kaleos) in louisiana................
 

· Registered
Joined
·
254 Posts
It's the gulf coast triangle effect......:eek: Before long your EVIC will start displaying random messages in cryptic code. :SHOCKED:
i'll believe the gulf coast triangle effect as long as my "x",:loser1: doesn't make it a complete triangle!!! she went from louisiana to tenessee to florida, as long as she doesn't make it back to louisiana, "everybody" will be okay.:smileup:

mcnabb (kaleos) in louisiana...............
 

· Registered
Joined
·
254 Posts
vinny, sorry to disappoint you, kind of disappointing myself also but i decided not to go to the dodge dealership on my bas light coming on since it went back off after the recent drives. i have other plans that have come up and i need to take care of these first. still, will let you know if it happens again.


mcnabb (kaleos) in louisiana................:wavey:
 

· Registered
Joined
·
172 Posts
Discussion Starter · #15 ·
Its all well and good. It comes one, but my Traction Control still works. I will be taking my Nitro into a dealership pretty soon.


vinny, sorry to disappoint you, kind of disappointing myself also but i decided not to go to the dodge dealership on my bas light coming on since it went back off after the recent drives. i have other plans that have come up and i need to take care of these first. still, will let you know if it happens again.


mcnabb (kaleos) in louisiana................:wavey:
 

· Registered
Joined
·
2,138 Posts
Its all well and good. It comes one, but my Traction Control still works. I will be taking my Nitro into a dealership pretty soon.
Read my post about 3/4ths down concerning the ESP light intermittently on. This won't help you necessarily fix the problem but may lend some understanding as to what might be the cause. Click HERE. Hope this helps. :smileup:
 

· Registered
Joined
·
172 Posts
Discussion Starter · #17 ·
Read my post about 3/4ths down concerning the ESP light intermittently on. This won't help you necessarily fix the problem but may lend some understanding as to what might be the cause. Click HERE. Hope this helps. :smileup:
I appreciate that. I was checking it all out. My wiring seems to be fine, from what I can tell. That meaning no cut or damaged wires and connections seated properly. Whether they are mated to the right connector, I dont know. Like I said, I will be getting my Nitro in soon.
 

· Registered
Joined
·
2,249 Posts
Sorry Vin, have not had that problem. I usually turn ESP off anyway.
Wish I had that problem!!! I also disengage the ESP right away when starting the Nitro, and wish it would STAY off until I wanted it back on (for another driver).

:thk:
 

· Registered
Joined
·
34 Posts
Yep, the light can on today....I started the nitro...switched to 4wd (alot of snow this morning)....pressed the brake shifted into Reverse and esp light came on, drove it a few miles still on.....You know, how many times and how many problems do we have to put up with, before I can actually enjoy the vehicle.....I bought it as a demo in Sept....12000km on it..now it has 15300kms and has been in for problem 7 times sometimes overnight and now it looks like a 8th time...for this problem and hopefully a new TC for the shutter in it......maybe shoulda got the GM instead.....

John
 

· Registered
Joined
·
172 Posts
Discussion Starter · #20 ·
Yep, the light can on today....I started the nitro...switched to 4wd (alot of snow this morning)....pressed the brake shifted into Reverse and esp light came on, drove it a few miles still on.....You know, how many times and how many problems do we have to put up with, before I can actually enjoy the vehicle.....I bought it as a demo in Sept....12000km on it..now it has 15300kms and has been in for problem 7 times sometimes overnight and now it looks like a 8th time...for this problem and hopefully a new TC for the shutter in it......maybe shoulda got the GM instead.....

John
I have the problems, but I have to think, there are only a few problems that I have had, and I have the first production year model of the vehicle. I know of several other vehicles that have had nothing but problems their first production year. Problems that end up rendering the vehicle undrivable. I will take these small annoyances over something like that. Bottom line, even with the issues, I really enjoy my Nitro.
 
1 - 20 of 20 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top