Dodge Nitro Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
All of a sudden my fog lights stopped working. The bulbs are good and they are the correct watts. I haven’t had any work done to my car. All of my interior and exterior lights work as they should. When I turn on the multi switch for my fog lights the fog light symbol doesn’t illuminate on the dash. What can I check or do to narrow this down. Could it be the multi switch? If so, how can I check this switch before replacing it? I ran 2 jumper wires to both fog lights individually to the battery to test them and they worked that way but they won’t work once I connected the wire harness back to them. Any help is appreciated because a few auto shops can’t figure this out either.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #3
Ok thanks for replying. Just to keep me from throwing parts at the fog lights, do you think thats 100% of my problem? I’m not doubting your knowledge of this.
 

·
Registered
Joined
·
993 Posts
Ok thanks for replying. Just to keep me from throwing parts at the fog lights, do you think thats 100% of my problem? I’m not doubting your knowledge of this.
If the fog light indicator doesn’t show on the instrument cluster after turning on the switch, I would assume it’s a bad switch. Or possible wire issue.
Turn them on with the switch and see if you get power to the sockets and the ground is good. Check the fuse. See if power is going to the fuse also (with the switch on)
 
1 - 4 of 4 Posts
Top