Dodge Nitro Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a 2007 with 104000. The blower motor doesnt always work. When it works all speeds work and blows air just fine. Yesterday while it wasnt working i had no power to fan switch. After restarting the car everything worked fine for my entire drive home.Third time it has done this.Is there a relay in the fuse box for this ? Any ideas?
 

·
Registered
Joined
·
5,160 Posts
you could try: when the blower motor stops working, switch the blower on, give the motor housing a tap with your hand ( from under the dash) not to hard but hard enough to give it a little shock, if the motor starts, this is a good sign that the bushes in the motor are worn or stuck,
or possibly somthing is stuck within the fan blades leaves etc.

there is no direct relay just for the blower motor, and the blower motor power feed comes straight from the fuse box (TIPM) so there is no direct fuse for the blower motor (TIPM controlled).
fuse M15 is the power feed to the blower control knob but also feeds other heater and A/C controls.

thats i how read it from the wiring diagram (someone will correct me if it's wrong).
 
  • Like
Reactions: Scar0

·
Registered
Joined
·
13 Posts
Discussion Starter #3
When it wasnt working I tried a new blower motor and that didnt work. Traced back to no power to inlet of blower knob on the dash. Drove it home sat. And in to work today and it worked just fine. All speeds all dampers worked. Maybe bad connection at tipm? Does the power from tipm go directly to blower control switch or to fan resistor?
 

·
Registered
Joined
·
5,160 Posts
at the blower motor there should be 2 wires:

1, Dk blu/Gry this wire goes from the blower motor to the resistors and the are fed with -12vdc (ground) through the blower speed control knob.
2, Dk Blu: direct +12vdc from the TIPM.

test these 2 wires with a multimeter, if your not sure how please ask.
 
  • Like
Reactions: Scar0

·
Registered
Joined
·
5,160 Posts
test agian if the blower stops working.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
The TIPM will kill power to a circuit if it senses a problem.
IE blower motor should be on and it is not.
You can try replacing the resistor.
 
  • Like
Reactions: Nitrogen

·
Registered
Joined
·
5,160 Posts
As ScarO points out, if the computerized fuse box (TIPM) detects a fault it will shut down the circuit, when the ignition is switch Off, then back On the circuit will reset, which may explain why the DK BLU wire has voltage intermittently.

a few members have had faulty resistor packs in the past.

my guess is either a loose fitting connector pin at the resistor pack, blower motor or TIPM, give the connectors a wiggle when the blower stops working, or when the blower is working wiggling the connectors may cause it to stop.

the blower motor control knob is fed by a Ground wire, which then feeds through the resistors depending on the blower speed selected, this ground wire could be loose or corroded, the ground point is located behind the front left kick panel ( however there are several ground points in this location).

the resistor pack can be tested with a multimeter.

maybe the heater control knob is defective.

Do you have Any other electrical issues ?.
 
  • Like
Reactions: Scar0

·
Registered
Joined
·
13 Posts
Discussion Starter #11
Had 1 time this winter turned key and nothing happened. Pulled battery cables cleaned them and that's been good. Radio works but mostly static.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
I have also put a new resistor in this winter fan only worked on high. Put new resistor in and all fan speeds work when its working.
 
1 - 13 of 13 Posts
Top