Dodge Nitro Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello, I hope I'm in the right place for this question .
So. Since the start of winter I have used up two full jugs of 50/50 premixed antifreeze (gallon sized) seems to me that's way to much...
I found the sight were it leaks from...I guess its burning off on the motor cause I've never seen any on the ground.???? So that's part of it, I had flushed the radiator and the heater core...this never made a difference with the heat, thermostat was good. Now the hoses to the core, my husband put them on backwards...making it flow the opposite direction. And just like that I have heat.
Turn them back and again no heat. What is that? Please tell me it's not hurting anything, I need the heat and told my husband to leave it...
I put a bottle of Barr's stop leak in the radiator. Seems to have stopped the leak, yet now I can smell the antifreeze when I first turn on the heat but just for a second. ( I will figure out the name to the site of were its leaking ) next post. Please bare with me, I am so lost! I really need your help and I truly appreciate all the advise I get. Thank you..
 

·
Registered
Joined
·
86 Posts
Can you take, and post, pictures of the way the hoses are when the heat works?
Also, see if you can see any signs of leakage when you first start it... before the engine gets hot enough to evaporate it, you may be able to see it dripping someplace which should help you see the source of the leak.
Good Luck R.lane
 

·
Khaki Nitro Nut
Joined
·
29,470 Posts
I never recommend using a leak stopping agent.
That being said, it sounds like the reverse heater hose connection is just working backward. My bet is the passenger side is now cooler then the drivers side. But this reverse connection will also flush whatever is in the core back into the engine.
Any odor of antifreeze in the cab is never a good sign. This indicates a bad heater core or hose connections.
 

·
Registered
Joined
·
7 Posts
Hello, I hope I'm in the right place for this question .
So. Since the start of winter I have used up two full jugs of 50/50 premixed antifreeze (gallon sized) seems to me that's way to much...
I found the sight were it leaks from...I guess its burning off on the motor cause I've never seen any on the ground.???? So that's part of it, I had flushed the radiator and the heater core...this never made a difference with the heat, thermostat was good. Now the hoses to the core, my husband put them on backwards...making it flow the opposite direction. And just like that I have heat.
Turn them back and again no heat. What is that? Please tell me it's not hurting anything, I need the heat and told my husband to leave it...
I put a bottle of Barr's stop leak in the radiator. Seems to have stopped the leak, yet now I can smell the antifreeze when I first turn on the heat but just for a second. ( I will figure out the name to the site of were its leaking ) next post. Please bare with me, I am so lost! I really need your help and I truly appreciate all the advise I get. Thank you..
I had a leak under my Nitro and it was because of a loose clamp on lower radiator hose. It was very hard to access because of the location. I had to use an adjustable ratchet to tighten clamp.
 

·
Registered
Joined
·
3 Posts
Hello, I hope I'm in the right place for this question .
So. Since the start of winter I have used up two full jugs of 50/50 premixed antifreeze (gallon sized) seems to me that's way to much...
I found the sight were it leaks from...I guess its burning off on the motor cause I've never seen any on the ground.???? So that's part of it, I had flushed the radiator and the heater core...this never made a difference with the heat, thermostat was good. Now the hoses to the core, my husband put them on backwards...making it flow the opposite direction. And just like that I have heat.
Turn them back and again no heat. What is that? Please tell me it's not hurting anything, I need the heat and told my husband to leave it...
I put a bottle of Barr's stop leak in the radiator. Seems to have stopped the leak, yet now I can smell the antifreeze when I first turn on the heat but just for a second. ( I will figure out the name to the site of were its leaking ) next post. Please bare with me, I am so lost! I really need your help and I truly appreciate all the advise I get. Thank you..
Its leaking in to your carpet,, that's where mine went.. you need a heater core,, you will have to remove the entire dash to get at the Hvac unit.... good luck, I was not happy neither.....
 
1 - 5 of 5 Posts
Top