Dodge Nitro Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello!
Recently, the lightning bolt warning light came on (Electronic Throttle Control). Sometimes it comes on, sometimes it doesn't. However, any time that the light does come on, the temperature gauge reads cold and will not move to warm as I drive. If the lightning bolt does not appear, the temperature gauge reads normal.

Thoughts? I am thinking of replacing the thermostat to solve the issue. Could it be a sensor or something else?

Not sure if this is related, but for quite a while, I have had the Malfunction Indicator Light on. The dealer said it was a small emissions leak and not worry about it. Could these problems be related?

Side note - I am also part of the "No heat on the driver side" club, as many are. I flush it occasionally to solve the problem temporarily. I did not know if the thermostat would affect that as well.

Thank you!
 

·
Registered
Joined
·
322 Posts
I think it's time you had your light scanned again. And if your going to flush your heater core again go ahead and flush the whole system and replace your tstat. Can't be sure your tstat is giving you issues though. Could be a coolant temp sensor. Can't be sure without more diag.
 

·
Registered
Joined
·
322 Posts
My biggest issue with leaving a check engine light not fixed is an evap leak will give you no running problems but with that light on there could be more faults. I've had many cars come in with customers claiming light has been on for years its nothing and I pull 15 or 20 faults out of it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
Thanks, Fastcompany. I had the light read last night and the P2181 code came on and recommended a new thermostat. This morning, I had a rough start (about 15 degrees outside) and the temperature gauge stayed at cold (lightning bolt went on) and the heater blew cold air on my entire drive to work. When I got to work, I turned the car off and then back on...the lightning bold did not come on and the temperature gauge went to normal.

I wish I could tell between the coolant sensor or the thermostat. My thought is that it is stuck open. What causes that?

I purchased one and am hoping to get it on this week. Is that a quick job (under an hour) or does it require quite a bit of disassembling?

Thanks again for the assistance
 

·
Khaki Nitro Nut
Joined
·
29,463 Posts
P2181 Cooling system performance. Possible causes; Radiator, coolant thermostat, engine coolant blower motor
I'd replace both the thermostat and the sensor. Neither one will break the bank. I'd also check the mix on the antifreeze, or flush and replace it.
 

·
Registered
Joined
·
322 Posts
Ya same thing. As a rule of thumb if I see a cooling system performance fault it always gets both. Some new cars have very expensive electronic t stats I'll put more diag in to that's about it.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
Thanks for the replies. The issue appears to have been fixed. I replaced the thermostat and I was also a little low on coolant. No more lightning bolt or check engine light.

I also had the heater core flushed again...I had heat for about 10 hours...then, as expected, the driver's side turned cold again. It's been between 5-15 degrees in Wisconsin lately, so it's been a real pain. I'll head over to the other thread for this issue.
 

·
Khaki Nitro Nut
Joined
·
29,463 Posts
Glad to hear one problem has been solved.
 

·
Registered
Joined
·
1 Posts
Hello!
Recently, the lightning bolt warning light came on (Electronic Throttle Control). Sometimes it comes on, sometimes it doesn't. However, any time that the light does come on, the temperature gauge reads cold and will not move to warm as I drive. If the lightning bolt does not appear, the temperature gauge reads normal.

Thoughts? I am thinking of replacing the thermostat to solve the issue. Could it be a sensor or something else?

Not sure if this is related, but for quite a while, I have had the Malfunction Indicator Light on. The dealer said it was a small emissions leak and not worry about it. Could these problems be related?

Side note - I am also part of the "No heat on the driver side" club, as many are. I flush it occasionally to solve the problem temporarily. I did not know if the thermostat would affect that as well.

Thank you!

I have the same issue. Replaced the thermostat and resevoir. Light came back on though.
 

·
Khaki Nitro Nut
Joined
·
29,463 Posts
Welcome to the forum @Cronan49. When you have a chance, head over to the Newbie Section (<click this) and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.
Did you replace the sensor?
Are you getting the same code?
 

·
Registered
Joined
·
1 Posts
Hi there I am having the same problem bolt light comes on dash, and Thermostat gauge drops below cold and fan starts going on.
I already changed thermostat 2 times
And sensors, radiator cap.
Not sure what I can be
 

·
Khaki Nitro Nut
Joined
·
29,463 Posts
Welcome to the forum @Tony12. When you have a chance, head over to the Newbie Section (<click this) and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.

Fan on is a failsafe when the computer does not get a temp reading it turns it on just in-case.
Did you replace the temp sensor with OEM or after market?
 

·
Registered
Joined
·
2 Posts
Hello!
Recently, the lightning bolt warning light came on (Electronic Throttle Control). Sometimes it comes on, sometimes it doesn't. However, any time that the light does come on, the temperature gauge reads cold and will not move to warm as I drive. If the lightning bolt does not appear, the temperature gauge reads normal.

Thoughts? I am thinking of replacing the thermostat to solve the issue. Could it be a sensor or something else?

Not sure if this is related, but for quite a while, I have had the Malfunction Indicator Light on. The dealer said it was a small emissions leak and not worry about it. Could these problems be related?

Side note - I am also part of the "No heat on the driver side" club, as many are. I flush it occasionally to solve the problem temporarily. I did not know if the thermostat would affect that as well.

Thank you!
Mine does the same thing. Checking the owner's manual and then viewing a couple You Tube videos the problem is diagnosed as a Throttle Body Issue. New ones are $500-600.00 but I found one through a local junk yard thats reconditioned for $70.00 .If you are mechanically inclined you can replace it yourself- just watch the videos.
By the way, there are many videos on YouTube that pertain to the Dodge Nitro. Just use the search link in YouTube.
 
1 - 13 of 13 Posts
Top