Dodge Nitro Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a 2011 Dodge nitro with a rhb head unit WITHOUT nav and had a stereo shop install it. They called oemauto to finish installation and said that their android phone wasn't compatible to program radio to finish proper function of backup cam. I plan to call them tomorrow as i work 12 hour nights. In the meantime i was wondering if anyone could point me in the right direction for possible info concerning a solution either in this forum or a local shop around houston, tx that someone has good past experiences with? Thanks in advance for the help.:thk:
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
EDIT - They installed the headunit a week ago and worked flawlessly but last night upon installation of lockpick they caused/couldn't figure out how to fix the problem with the back up cam coming on randomly and only showing a black screen.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thank you, meder, for your prompt response. That is what I did and after talking with them I took it to a shop they recommended after I asked who they had positive experiences with before in the Houston area. Turns out a pin was bent by the installers inside the harness. And the brand new backup cam itself was broke. I took it back to the original shop and told them what they should have known and they fixed it. No biggie, except the owners son then preceeded to tell me that'swhy they quit carrying the llock pickbrand and use another ccompanies harness. But I guess he was too dense to realize that same problem, which they created, would have happened on their preferred lockpick harness as well. They do great work overall, so I bit my tongue. It is freaking awesome though!
 

·
Lighting Guru!
Joined
·
3,633 Posts
Great to hear that you got it working. Thank you for getting back about how it was fixed, most ask a question and never return with a solution.
 

·
Premium Member
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
ArcAngel this is the second time I have heard of installers bending pins when doing an install. Guess we now have more information for the next time something like this happens. Thanks for getting back to us. :rep:
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top