Dodge Nitro Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello all, hopefully I can get some insight from here.

First off thank you for the add.

I have a 2008 slt 3.7 2wd 156k miles.
Bought it with 33k miles in 2012 from original owner.
At 90k had to replace Tipm.
At 140k had a cam follower lock up and threw rocker arm off busted the valve spring and chipped the cam. Got all that fixed (last july)

And now this.
My wife was driving friday night and the car just shut off and died.
Was throwing the lighting bolt light and check engine light.
Pulled codes.
1. Throttle/ pedal position sensor/ switch A circuit high.......this code is active will not clear

2. Crankshaft position sensor A circuit. Thos code is pending and will reset

Code 2 comes back after what seems like the 30sec cranking cycle but will still clear.


Did some research and found that a bad/dirty map sensor can cause this issue

Cleaned map now it will run but It takes it some time to actually fire up and I have no throttle control I can hold it on the floorboard and it sets at idle rpm

I have a new throttle body but was told if I installed part and didnt fix issue that I can not return part $300

Has anyone else ever had this issue? If so what route did you take.

Thank you again for the add and thank you in advance for any help that is given
 

·
I work so I can... SQUIRREL!
Joined
·
2,516 Posts
Good to have you here. Enjoy the forum!

BTW... Post a pic of your Nitro when you can.
 
  • Like
Reactions: Scar0

·
Khaki Nitro Nut
Joined
·
30,219 Posts
Hello and welcome Adrian,
to the Nitro “Z” family!
I posted in your other thread.
I'm looking forward to your future posts & Pics. We love Pics here!
We also like new Mod ideas.

Enjoy the forumZ.
Scar

BTW;
If you could please go to your personal-details and fill in the “Vehicle:” info about your rig. It will be easier for us to answer your questions down the road, without us having to ask a bunch of questions.

As you can see at the left of every post I make, under my Ape Avatar;
This is what I drive:
Vehicle:
07Lifted,4X4,6sp-man,3.7L
Or alternately you could put it in your signature...
 
1 - 6 of 6 Posts
Top