Dodge Nitro Forum banner

1 - 5 of 5 Posts

Registered
Joined
2 Posts
Discussion Starter #1
Hi! My name is Laura. I have a 2007 Nitro R/T that I am the first owner of. It has around 247,000 miles and has been an excellent vehicle. I have had multiple issues that I have been able to self correct or diagnose then have fixed if beyond my scope. Currently I am struggling. I recently10/26/19 had radiator replaced, the serpentine belt fixed, followed by the fan clutch replacement. When I started vehicle it made this horrible sound so I took it back, they said it was fine. I drove it for a bit then it started running high/rich and idles at 1.5. I waited, and thought it might settle, then my Nitro died in the middle of an intersection in 15 below weather. Several really nice men pushed it to a car shop that had worked on it previously. The new findings were regarding an alternator issue which had previously not been an issue. I had them replace it as well as the battery which was a top of the line and only a year old. My Nitro sounds horrible, running poorly, and new engine lights pop up everyday. I love my Nitro, really want to get it to at least 300,000. At least but I need some advice. All help wanted馃榾
 

Registered
Joined
2 Posts
Discussion Starter #2
Hi! My name is Laura. I have a 2007 Nitro R/T that I am the first owner of. It has around 247,000 miles and has been an excellent vehicle. I have had multiple issues that I have been able to self correct or diagnose then have fixed if beyond my scope. Currently I am struggling. I recently10/26/19 had radiator replaced, the serpentine belt fixed, followed by the fan clutch replacement. When I started vehicle it made this horrible sound so I took it back, they said it was fine. I drove it for a bit then it started running high/rich and idles at 1.5. I waited, and thought it might settle, then my Nitro died in the middle of an intersection in 15 below weather. Several really nice men pushed it to a car shop that had worked on it previously. The new findings were regarding an alternator issue which had previously not been an issue. I had them replace it as well as the battery which was a top of the line and only a year old. My Nitro sounds horrible, running poorly, and new engine lights pop up everyday. I love my Nitro, really want to get it to at least 300,000. At least but I need some advice. All help wanted馃榾
I found I speak and write like a teacher. My questions are...
Would the replacement of the radiator require the battery to be unconnected and not reconnected correctly causing an issue with the fan and it needing replacement, that lead to battery and alternator also needing to be replaced? Since getting Nitro back, it starts rough, and idles high. Ideas/thoughts?
 

Just chasing my tail
Joined
2,347 Posts

Good to have you here. Enjoy the forum!

BTW... Post a pic of your Nitro when you can.
 

Khaki Nitro Nut
Joined
29,327 Posts
Hello and welcome @Labrewer, to the Nitro 鈥淶鈥 family!

This can get far to in depth for the newbie section. If you post your Q in the correct section we can start in on helping to trouble shoot this issue.
But for now, it sounds like there is a vacuum leak causing the high RPM.
I'm looking forward to your future posts & Pics. We love Pics here!
We also like new Mod ideas.

Enjoy the forumZ.
Scar

BTW;
If you could please go to your signature (<click this) and put your info about your rig on the first line. It will be easier for us to answer your questions down the road, without us having to ask a bunch of questions.

As you can see under every post I make;
This is what I drive:
07Lifted,4X4,6sp-man,3.7L
 
1 - 5 of 5 Posts
Top