Dodge Nitro Forum banner

1 - 8 of 8 Posts

Registered
Joined
3 Posts
Discussion Starter · #1 ·
Found this website on the web. I need help, iv got an 07 nitro that ran fine all the way uo untill yesterday, started right up no issues, took my son to school and came home. The wife went to leave few hrs later and the vehicle does NOTHING!!!! YELP At the drop of a hat NOTHING!! No dash lights etc. As if the battery randomly died?? So i go to jump it and still nothing.....?????馃 so i check fuses under the hood and all check out???馃馃 so perhaps the battery has voltage but no out put so i switch batteries and still nothing馃馃 at this point im at a loss and need help. Thinking possibly a computer but i want to check before i go wasting money and help would be greatly appreciated

P.s. already done global shut down over night and still nothing
 

Registered
Joined
5,197 Posts
Hi and Welcome,
my first guess would be a corroded ground wire, underneath the battery, when the battery is removed you can see a large bundel of ground wires bolted to the chassis, when i checked mine it was badly corroded, also check the large positive wire going to the TIPM (computerised fuse box),
 
  • Like
Reactions: Scar0

Registered
Joined
3 Posts
Discussion Starter · #3 ·
I checked the one at the tipm bc is was green tarnished but not coroded but i noticed as i unhook the battery then rehook it wants to run the washer fluid pump and if i do that again the horn would honk either or either time馃馃 like there is a short somewere, but ill check the grounds tomorrow as i have to go to work, they under the battery tray?? Bc with the battery out i didnt see wires as i didnt really look for them lol
 

I work so I can... SQUIRREL!
Joined
2,613 Posts

Good to have you here. Enjoy the forum!
BTW... Post a pic of your Nitro when you can.
 

Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
30,638 Posts
Hello and welcome @Ramking 93, to the Nitro 鈥淶鈥 family!

In my 07 the horn honks 1 short honk every time I connect the battery.
The washer fluid weeping is not a good sign.
I'm looking forward to your future posts & Pics. We love Pics here!
We also like new Mod ideas.

Enjoy the forumZ.
Scar

BTW;
If you could please go to your signature (<click this) and put the info about your rig on the first line. It will be easier for us to answer your questions down the road, without us having to ask a bunch of questions.

As you can see under every post I make;
This is what I drive:
07Lifted,4X4,6sp-man,3.7L
 
  • Like
Reactions: intruder
1 - 8 of 8 Posts
Top