Dodge Nitro Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hi guys newbe here looking for a bit of helpful advise as I'm not getting anywhere,I'm in the uk and there's not much in the way of nitro knowledgable mechanics, there's not much info on the interweb about my particular problem regarding the 2.8 crd.
Well I'm getting a bit of hesitation when driving off turbo at a constant speed but when you accelerate turbo kicks in fine and off she goes. I find myself accelerating then decelerating constantly trying to miss that middle judder/ kangarooing when driving at a constant speed.
I'm getting constant limp mode,eml & code p0299 under boosting bla bla.
Being the 2.8crd there's not much in the way of turbo vacuum pipes but the few pipes there are I've removed and inspected and visual inspection of the turbo which the compressor wheel moves freely with no play or oil in the turbo or pipes so I'm ruling out turbo ,vacuume lines so far.
Now I'm used to working on petrol turbos ,scoobys ,skylines that sort of thing so I'm unsure of the workings of this type of actuator that's on these ! It seems totally electric and can't find any vac lines in/out ,just a electric plug . So could anyone shine any light on the workings of this and/or reliability or any ideas on my problem would be great . It would get the wife chewing my earol off as its her school run car
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
P0299 Turbocharger (TC)/supercharger (SC) - low boost Mechanical fault
Have you checked the pipes that go to the turbo?
The OEM rubber pipes are known for splitting.
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
It only takes a small split for this to happen.

Set Condition: P0299
The Boost Pressure Sensor indicates actual turbocharger boost is less than the ECM setpoint for engine boost for 0.83 second.

Possible causes:
CLOGGED AIR FILTER
INTAKE AIR RESTRICTION
INTAKE AIR LEAK
BOOST PRESSURE SERVO MOTOR
TURBOCHARGER
Check the EGR Valve to make the valve is not stuck in the closed position.
Check the Air Filter for soiling or excessive dirt which may cause air flow restriction
Check the Boost Pressure Servo Motor and ECM harness connectors are connected and the wires are in good shape.
Lastly seal the system and smoke test it. If no leaks are found the SM suggests replacing the turbo assembly.

EDIT:
One more thing to try. Remove the Neg(-) battery cable for 10 minutes. This will reset the computers, just in case it is a glitch.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
I've stripped the ic hoses on non turbo side and found a 2 in split in the large pipe that goes from the intercooler to the top of the engine. It's split on the outside and when squeezed you can see all the canvas inside the rubber has split also but can't quite see if it's gone all the way through . I've gaffer taped up as best I can until I can get a new pipe. Seems to have cured the problem but it seems to come and go before so we will see how it goes.
Thanks for your help !
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
Your welcome.
Thanks for getting back to us. I believe you have found the issue.
Your temp fix will not last long, and neither will a new rubber pipe.
I have heard good things about the tomgan pipes for the Nitro.
They are a little spendy, but I've heard they will last.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
Yes I've looked at them and they are pricey , I recon I could get some pipes bent and cut the ends off my own pipes ,few jubly clips and jobs a goodun for less than £100. That's just extortionate money. Surely they do a samco hose kit for the dodge somewhere ?
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
Not a bad price at all. Keep us posted on how they work/last. I know other CRD owners would be interested.
 

·
Registered
Joined
·
92 Posts
Mine exploded 3 rubber hoses in 3 years.

i solved with the german aluminium custom kit (less than 500 € both hoses)


in ita, delaler want 350 € for a SINGLE hose & install
 

·
Registered
Joined
·
4 Posts
Hi all
I own Jeep J8 which has the same engine of dodge nitro 2.8 crd. I have same issue exactly. If I drive in constant speed the Ecu goes in limp mode and throwing code P0299. I replaced
New Turbo
New Turbo actuator
New Turbo hoses
New MAF Sensor
New MAP sensor
And I'm still greeting the same thing.
Anyone can advise for a solution please
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
Hi all
I own Jeep J8 which has the same engine of dodge nitro 2.8 crd. I have same issue exactly. If I drive in constant speed the Ecu goes in limp mode and throwing code P0299. I replaced
New Turbo
New Turbo actuator
New Turbo hoses
New MAF Sensor
New MAP sensor
And I'm still greeting the same thing.
Anyone can advise for a solution please
Welcome to the forum @M.Fakhri.
See post 4 and 5 above.
 

·
Registered
Joined
·
4 Posts
Welcome to the forum @M.Fakhri.
See post 4 and 5 above.
Thank you for the quick reply. Please find below all the action which was taken since the issue started based on post 4

CLOGGED AIR FILTER

Since it is J8 so it has special air filter and intake so I removed the filter and test it it was just the same.

INTAKE AIR RESTRICTION
Like what?

INTAKE AIR LEAK

Yes I found Lil damage in the elbow but it is not causing any leak. Also I fount the hose which is coming from CCV is loss and it been fixed. I only need to confirm if is it normal to get air flow from CCV if the engine is off or at idle?

BOOST PRESSURE SERVO MOTOR

Replaced with new one. Also I tested few days back by simulation using Autel pro diagnostic tools and it just work fine with all the commands I gave
0%, 10%, 20% 40% 60% 80% and 100%

TURBOCHARGER

Replaced new with new one also I inspected few days back it was moving freely with out any play up down lest and right. I just found Lil black smoke mark near the wastegate stick. Is it normal?

Check the EGR Valve to make the valve is not stuck in the closed position.

I removed it and give it good clean. It seems like in good condition. Also I disconnected the vacuum hose and test drive it and I can feel the different in power and it also did it.

Motor and ECM harness connectors are connected and the wires are in good shape.
I think if the connectors or wires has an issue it will do it at any speed. But in my case it only does it at constant speed

Lastly seal the system and smoke test it
I'm planing to do it. But I inspected all the hoses and everything seems OK. I think even if it has Lil leak it should also cause an issue while accelerating too.

Please let me know if you recommend any othere thing to be inspact
 

·
Registered
Joined
·
4,906 Posts
also found info on some French forums:

i Don't know why but several sites mentioned "low engine oïl pressure" as 1 of the causes for setting the P0299 code,
a crack in the metalwork or castings somewhere in the pressurised side of the turbo system,
a blocked DPF if your vehicle has one fitted
and the most common fault is the boost pressure servo motor Sticking When " HOT "(very important), or possibly not calibrated correctly.

thats all i got.
 

·
Khaki Nitro Nut
Joined
·
29,722 Posts
Damaged, restricted or poorly connected intake and turbocharger related tubes can cause the P0299 code to set. As well as a clogged air filter.
 

·
Registered
Joined
·
4 Posts
Let's discuss solutions one by one and the action and test which was done by me. Maybe you can advise me for other type of test

Turbo boost actuator
I checked it by Autel diagnostic tools. By forcing it to open 20% 40% 50% 60% 80% and 100% and all went OK it went to the right % as per the giving command. The only thing which I can't confirm is it getting stack because of the heat and it is stop working and causing the engine to go to limp mode

Leak in hoses or manifold
I inspected everything by eyes and I blow some air using my mouth and I didn't see any serious leak.

Clogged air filter
I removed the air filter and give it a test drive issue still showing.

Oil preusser pump
I dnt know how I can check it

Can anyone give me the location of the exhaust pressure sensor in wrangler jk 2009.i looked everywhere but I couldn't find it
 
1 - 20 of 20 Posts
Top