Dodge Nitro Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2011 dodge nitro 4.0 93k miles

I went to turn on the heat and nothing worked it just started yesterday. My A/C or any kind of air is not blowing at all. I looked at the fuses and swapped some around to matching ones and no change. I hear the condenser when I turn on the A/c. I was thinking the blower motor resistor but idk. I look off the back of th a/c controls but didn't unscrew the back completely. I was looking for loose wires. The controls turn on but I can't tell if they are the issue.

Any advice ?
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Welcome to the forum Casey platinum.

When you have a chance, head over to the Newbie Section and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.

First thing (If you have a my gig radio, pull the fuse for it first,) is to try is a Neg(-) battery cable disconnect for 10 minutes. This will rest the computers if there is a glitch.
 

·
Registered
Joined
·
5,160 Posts
could be the brushes in the blower motor,

this is worth a try: turn on the blower motor, then from underneath give the motor a few taps with your hand, sometimes this will be enough to jolt the brushes back to life.
 
  • Like
Reactions: Scar0

·
Registered
Joined
·
2 Posts
Discussion Starter #4
I will head over to the newbie section. I ordered the blower motor resister at Oreillys the special order one. It costs $44.03. It was easy to install and guess what? It fixed the issue
 

·
Registered
Joined
·
5,160 Posts
Well done Casey
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Good news! Glad to hear things are as they should be again for you.
 
1 - 6 of 6 Posts
Top