Dodge Nitro Forum banner
1 - 17 of 17 Posts

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #1 ·
thanks so much for this forum....as much as Nitros are hated by so many,I love mine!....2008 SLT....it's been an awesome vehicle for me ....knock on wood,in the 12 years since I drove it off the lot alll I've had to fix is the water pump and brakes,I've babied it since the day I got it...still looks like the day I drove it off the lot....

recently no heat!....did my research on youtube and here and figured it was clogged since i have no leaks...took it for a coolant/engine flush and had proper pressure so I knew it must be clogged ....could'nt believe all the shit that came out when I super flushed the core....make a long story short ,I now have heat again!! thanks to everyone who contributes

cheers...stay safe everyone !!
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #2 · (Edited)
sorry I know there are many threads on this topic but I'm getting old and confused and have a hard time following all these threads so thought it easier to just start my own lol ....thanks so much to you all! what a fantastic site for all of us Nitro owners!!


I thought I had my problem solved ....I've flushed the heater core numerous times with Prestone flush and Super clean flush....I got heat back but it wasn't very hot but hot enough to deal with winter....last night I was warming it up at work and it started to over heat...my heater gauge started rising...I let it cool down popped the rad cap and squeezed it to make sure spring not seized...it did have a big air pop when I took it off making me believe some air was still trapped...it worked,not over heating now but no heat!!!!
so I saw a youtube vid of a guy flushing with muratic acid,I know! scary but I figure I have nothing to loose...so this morning I flushed again with a 60/40 mix of acid and water...I did this 6 times both ways...Holy shit! could'nt believe the shit that came out....obviously did'nt get it all with the Prestone and Super clean,I filled core with antifreeze put hoses back on and ran vehicle with rad ca off to burp out any air left in system,have heat but again not as hot as it should be...starting to get discouraged ugh.....so frustrating...I've ruled out the actuator doors etc...no visible leaks or smells so the only other thing I can think is to replace the thermostat?.... am I missing something?

can someone post a pic of the location of the air bleeder?....think someone said in another post its on the timing cover or something?...I'd like to try bleeding more air while the system is closed ...rad cap on etc...I guess it would be worth changing the rad cap to even though it seems to be ok?
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #3 · (Edited)
wow! getting extremely frustarted and discouraged...I really don't want to have to replace core...thought I had the issue fixed...last night I was warming up the truck after work...all of a sudden it started to over heat ugh...shut her down and let cool down,removed rad cap with a 'pop'...so figured air still in system...checked rad cap seems ok,let truck run with cap off to remove any air...put back on seemed to work but now no heat....I recently had a full flush done so I'm thinking some more debris got caught up in the core again...so this morning I did another flush of the core...I saw a guy on youtube use a 50/50 mix of muratic acid and water...so I thought I'd give it a try since I have a pool and have muratic acid on hand....so I flush both ways using a 60/40 mix of acid amd water....HOLY SHIT!! could'nt believe how much more crap came out,so I put everything back together and ran the truck with rad cap off to burp the air out....I was excited thinking this will solve the prob....well I do have heat but not as hot as I think it should be and its not over heating anymore...I don't have any leaks that I can see,don't smell anything ,the actuators are working etc etc....so I'm stumped...would it be worth while to change the thermostat and rad cap??....I'm at my wits end ...I'm thinking it's coming to the end and maybe I should just get a new vehicle but i love my Nitro,it's been great to me over the last 12yrs...just put new muffler,tires,oil,brakes,flush etc so everything is great except this heat problem...I live in Canada and need heat....wife is against me getting a new vehicle because she looks at my truck and it looks brand new still,paid for etc...why get a new vehicle and have payments ...I said to her easy for you to say with your heated seats etc lol....try driving all winter with no heat trying to keep windows defrosted etc...I bought a plug in seat heater last winter and pretty much only used truck to goto work....everything else used wifeys vehicle....my a/c still works great...everything is good except this heat issue...I'm thinking to replace the thermostat and rad cap...if this doesn't fix the issue i think I'm going to pack it in and get something new ;(
btw when I got the flush done they used a universal coolant...guy told me its ok for all vehicles??...i noticed my coolant is looking kinda beige now whenit should be the neon green color...please tell me its just some of the old antifreeze mixed with new that was maybe left behind...last thing I need is oil in my antifreeze....that means goodbye to my Nitro ;(
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #4 ·
well thought I had it fixed...started to overheat again ugh...I'm so frustrated
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
What rig do you drive?
BTW;
If you could please go to your signature (<click this) and put the info about your rig on the first line. It will be easier for us to answer your questions down the road, without us having to ask a bunch of questions.

As you can see under every post I make;
This is what I drive:
07Lifted,4X4,6sp-man,3.7L
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #6 · (Edited)
Thanks Scaro...I put my vehicle type under my profile to
well my heat prob has got worse !!!

now have the PO2181 code so I'm thinking thermostst is shot....truck overheating and getting smoke through my defrost vents inside truck :(....when i turn heat on the temp goes down which makes me think thermostat again...when i shut truck down I hear a gurgling type sound up in dash by defrost vents ...fans are working but seem to hear a whine....I din't know getting very frustrated ....waiting to hear from a mechanic who is a friend of family

when I got the coolant flush they put a universal coolant in...now seems to be low i ended up adding mopar coolant that is originally for the truck ...will this cause further damage?...when i get it to my friends shop Ill have it all flushed out again and filled with proper mopar anitfreeze...
i'm thinking thermostat and water pump bot need replacing ugh
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #7 ·
think thermostat is seized ...I'm going to take to a friends shop since he has the proper tools to flush the system properly ...think I'll end up replacing the water pump to for the 2nd time....if this does'nt work I think it's time for a new vehicle...going to miss my Nitro
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
The bleeder is a bolt on top of the thermostat housing, right up front.
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #9 ·
looks like i'm getting a new rad
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
P2181 = Cooling system performance. Possible causes; Radiator, coolant thermostat, engine coolant blower motor, Trapped air.
Where is the temp reading in the gauge? Is the outside temp reading correct on the dash?
The system needs pressure to work correctly. If the Rad cap is not holding, the circulation will not be working right.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Just thought of something else. Lots of bugs in the rad or condenser will prevent proper air flow.
 

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #12 ·
Y
P2181 = Cooling system performance. Possible causes; Radiator, coolant thermostat, engine coolant blower motor, Trapped air.
Where is the temp reading in the gauge? Is the outside temp reading correct on the dash?
The system needs pressure to work correctly. If the Rad cap is not holding, the circulation will not be working right.
The outside temp on dash is correct ...engine temp fluctuates from 1/2 where it normally should be to 3/4....when I put heat on I’m getting hot ,then cold and I’m also gettting smoke or steam up through defrost vents.
I do t see any leaks and I have added some a it freeze but because I flushed the core
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,657 Posts
Check on the ground under the drivers floorboard. That is where the A/C condensate drain leads to. If you see coolant on the ground, or in the front floorboards, your heater core is popped.
 
  • Like
Reactions: db57 and Nitrogen

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #14 ·
Check on the ground under the drivers floorboard. That is where the A/C condensate drain leads to. If you see coolant on the ground, or in the front floorboards, your heater core is popped.
thank you for trying to help...I don't see any fluids on the ground or inside the vehicle...I can see a pipe that runs along bottom of windshield under the vent housing on the exterior of the vehicle...what is that?
i will take a pic
I'm heading to dealership to pick up a rad cap,thermostat and coolant ...my friend who's been a mechanic for 40yrs has turned his garage into a shop with a full hoist and everything so he can work from home...he's reached out to me to help me because I posted on facebook looking for help....he truly believes in OEM parts ans hates after market shit so told me to go pick up parts from dealer and he will put in no pats for me and try to fix....if it is the core then I'll deal with one more winter and tackle it in the spring...main thing is to have engine and coolant clean and running properly and we will bypass the core for the winter...I'll just have to deal with it....I'll plug in an inverter and use a heater in the truck when needed ...worst case,if its not the core then things should be ok

yesterday i had to add about half jug of mopar coolant to the universal coolant mr lube put in...hope this does'nt f it up...i only drive 10mins to work and back...last night I drove without using heat at alll...kept it off and truck ran at normal temp....seems to only get hotter when running heater which makes me think i have a blockage,air or pressure??
thanks again for your time
 

·
Registered
Joined
·
56 Posts
when I put in a new water pump I had to lift the passenger side front up to do a complete burp of the system ran it for about 15 min.
could you have a vapor-lock in the system?
also if you're adding a lot more to a full system coolant has to be going somewhere, like out the heater-core system, out the exhaust or in the oil.
 

·
Registered
Joined
·
5,225 Posts
thank you for trying to help...I don't see any fluids on the ground or inside the vehicle...I can see a pipe that runs along bottom of windshield under the vent housing on the exterior of the vehicle...what is that?
i will take a pic
I'm heading to dealership to pick up a rad cap,thermostat and coolant ...my friend who's been a mechanic for 40yrs has turned his garage into a shop with a full hoist and everything so he can work from home...he's reached out to me to help me because I posted on facebook looking for help....he truly believes in OEM parts ans hates after market shit so told me to go pick up parts from dealer and he will put in no pats for me and try to fix....if it is the core then I'll deal with one more winter and tackle it in the spring...main thing is to have engine and coolant clean and running properly and we will bypass the core for the winter...I'll just have to deal with it....I'll plug in an inverter and use a heater in the truck when needed ...worst case,if its not the core then things should be ok

yesterday i had to add about half jug of mopar coolant to the universal coolant mr lube put in...hope this does'nt f it up...i only drive 10mins to work and back...last night I drove without using heat at alll...kept it off and truck ran at normal temp....seems to only get hotter when running heater which makes me think i have a blockage,air or pressure??
thanks again for your time
don't run an inverter with an electric heater, it will draw too many Amps and could burn out the charging system,
 
  • Like
Reactions: Scar0

·
Registered
2008 Dodge Nitro SLT (black)
Joined
·
33 Posts
Discussion Starter · #17 ·
don't run an inverter with an electric heater, it will draw too many Amps and could burn out the charging system,
I’ve given up. I finally even tried a aluminum sealer product because at this point I’m going to end up replacing rad and core. Got some heat back but not much. Of course came across another prob while working on it. Transmission lines almost rotted through at the clips so they will need replacing. Quote for parts , both sets are $200 each,after market rad $198 and core is $110. So I’m up over $700 in parts doing the work myself. As much as I love my nitro I think it might be time to move on because I have a feeling it’s going to be repaired after repair now ugh
 
1 - 17 of 17 Posts
Top