Dodge Nitro Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Well not off to a very good start. 2011 nitro shock 178kms owned it for about 3 weeks, this morning just cranks and no start. YES i can hear the fuel pump for about 3 seconds, security light on the dash and tire monitor, so my friend at local dealer says " thats not good lets check for recalls first, regardless it has to come here to get reprogrammed". He couldnt tell me what he thought because he was at work, totally understand.

that sounds like money to me. I did disconnect the battery and pulled the " IOD" fuse at the same time for about 40 min (no key in ignition for the 40 min ). The battery is good even tried boosting as well temp is about 32f here

Any suggestions before it goes next week, i have read lots but not gonna thro parts at it if it has to go to the dealer anyway for reprogramming

Thanks
JimmyB.
 

·
Registered
Joined
·
61 Posts
I usually start with changing spark plugs if I don’t know service history. It costs very little and can often solve the cranking but no starting problem.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,459 Posts
Answered in other thread.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Well not off to a very good start. 2011 nitro shock 178kms owned it for about 3 weeks, this morning just cranks and no start. YES i can hear the fuel pump for about 3 seconds, security light on the dash and tire monitor, so my friend at local dealer says " thats not good lets check for recalls first, regardless it has to come here to get reprogrammed". He couldnt tell me what he thought because he was at work, totally understand.

that sounds like money to me. I did disconnect the battery and pulled the " IOD" fuse at the same time for about 40 min (no key in ignition for the 40 min ). The battery is good even tried boosting as well temp is about 32f here

Any suggestions before it goes next week, i have read lots but not gonna thro parts at it if it has to go to the dealer anyway for reprogramming

Thanks
JimmyB.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Well back from the dealer. Starts again. 👍
The problem was at the C2 or C4 connector with corroded terminals. Apparently the is where the communication to the injectors Is locates. Reason for not starting they said.
So we install a no warranty $300cad TIPM a new one was $1400cad with 2year warranty parts and labor

so$613 later I’m rolling again

from the pic could this have need cleaned up greases and sealed
I did keep the old TIPM box
39447
75F05A02-B57E-4842-8187-2E3D6F7B6944.jpeg
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,459 Posts
Looks to be the ASD relay they jumped.
But I am also curious what the 30Amp fuse and relay to the left of the wire are for.
Mine does not have those and I can't find a listing for them.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Not Sure on the 30amp fuse ?? Tow package maybe.
I did pull the tipm all apart and found the corroded boards (3&4) so I got a tipm out of a dodge caravan hoping to just swap boards 3&4. No luck, they are actually a little different. Mine is a Rev 2 whereas the caravan was a Rev 1.
But luckily the actually terminal legs that I needed were the same (L-21 and L-22)
Replaced those and all back together and hopefully it will be a swap out for the next time
Not sure if this made sense. But to those that have taken a tipm apart you understand
Thanks and YouTube “Mak’s tipm repair”
Good info as well as their website
Thanks again
 
1 - 9 of 9 Posts
Top