Dodge Nitro Forum banner

301 - 320 of 323 Posts

·
Registered
Joined
·
32 Posts
:cool: Looking forward to the results.
Noticed I have a small drip from one of the fittings so I have to pull it to reseal but want to test it out and make sure I don't need to flush it again. About to head out for work so should know soon enough. But there is a YouTube video of an XJ owner that did this and a follow up with him cutting the filter open 6k miles later and a lit of junk caught in the filter. Pretty cool to see.
 

·
Registered
Joined
·
9 Posts
Hey all! Just thought I'd check back in to see if a perm fix has been found for this issue.
So far I've had all the doors and actuators replaced. The heater distribution box replaced. Two heater cores complete with regular flushes. And yet, still experience this issue during the winter time. I had the heater core flushed back in October, and now will be taking it back to Grismer to have it flushed... again.
At this point, I hate this Nitro (a little bit) and am ready to sell it!
 

·
Registered
Joined
·
32 Posts
So far, the coolant filter is working fantastic. Blend door actuator is getting replaced this weekend but think the filter is an effective solution. And under $50 to biit!
 

·
Registered
Joined
·
5 Posts
Hi I have a question I have same issue passenger side good warm driver side cool but have a slite oder can give me a headache only when have heater on is it the heater core needing replacement?? Help please
 

·
Khaki Nitro Nut
Joined
·
29,740 Posts
Hi I have a question I have same issue passenger side good warm driver side cool but have a slite oder can give me a headache only when have heater on is it the heater core needing replacement?? Help please
Is the smell kinda sweet? With just the heat on (Not A/C) do you have a puddle forming on the floor boards or under the rig?
 

·
Khaki Nitro Nut
Joined
·
29,740 Posts
The smell could be mold in the HVAC system. The smell I was asking about was antifreeze smell. But if you are not loosing coolant that is not likely.
To fix the heat issue you will need to flush the heater core several times in both directions.
 

·
Registered
Joined
·
11 Posts
The smell could be mold in the HVAC system. The smell I was asking about was antifreeze smell. But if you are not loosing coolant that is not likely.
To fix the heat issue you will need to flush the heater core several times in both directions.

I had the same heating issue on my Black 2010. I ended up disconnecting the vehicle heater hoses , attaching some heater hose with a garden hose fitting and filling it with radiator cleaner, I let it sit for an hour then flushed it out. I then reversed the hoses and refilled with cleaner and flushed the other way. So far no more problems and it gets really hot, both sides now.
 

·
Registered
Joined
·
24 Posts
I have gone through the same issue and even wrote to the canadian dodge arbitration board. How is this not a recall issue.

Hey all! Just thought I'd check back in to see if a perm fix has been found for this issue.
So far I've had all the doors and actuators replaced. The heater distribution box replaced. Two heater cores complete with regular flushes. And yet, still experience this issue during the winter time. I had the heater core flushed back in October, and now will be taking it back to Grismer to have it flushed... again.
At this point, I hate this Nitro (a little bit) and am ready to sell it!
 

·
Khaki Nitro Nut
Joined
·
29,740 Posts
I have gone through the same issue and even wrote to the canadian dodge arbitration board. How is this not a recall issue.
Recalls are only related to safety issues. Plus the Mgf has an out if you do not use only their (Sold by Dodge) coolant. Then they can say it was caused by incorrect coolant. Only use HOAT coolant in the Nitro. Zerex G-05 is what I use. It meets Mopar HOAT standards (MS-9769).
 

·
Registered
Joined
·
4 Posts
My 2008 is still having heat issues, it is now warmish on the passenger side and cold on the drivers side.Will blow very warm for a minute after first turning it on. Both heater core and air distribution housing have been replaced about a year ago. Is it possible the new heater core is clogged already?
 

·
Registered
Joined
·
14 Posts
Hey all! Been awhile but have an issue. Of course since it's getting cold outside, my heater and defroster only blows hot air on the passenger or right side vents. The left side seems to blow cold air or vent temp. air.
Any help with this problem would be great! Wife drives it and we're supposed to have a chance for freezing rain and possible snow Thursday night! So I need to figure this out QUICK!
 

·
Registered
Joined
·
11 Posts
It's possible. I would flush mine a it would work great for a couple of weeks and be back to no heat again.
Are you flushing both ways?
I attached my garden hose to the heater hose connections and flushed, then changed the hose position and repeated. In between that, I filled the core with radiator cleaner and let it sit and soak for 30 mins. Took all afternoon, but no problems since then.
 

·
Registered
Joined
·
32 Posts
Are you flushing both ways?
I attached my garden hose to the heater hose connections and flushed, then changed the hose position and repeated. In between that, I filled the core with radiator cleaner and let it sit and soak for 30 mins. Took all afternoon, but no problems since then.
The last time before I put the coolant filter on, I flushed both ways several times, use cleaner... I spent almost 2 hours! Few weeks later, hot cold on driver's side again. Since installing the filter though, zero problems.
 

·
Registered
Joined
·
1 Posts
Heater seems to work as far as coming out vents, floor and all combinations of air flow but temp on drivers side is cold.
When defrost is set it feels like AC blowing through the vent drivers side.

Any help would be appreciated.
 

·
Registered
Joined
·
2 Posts
2007 nitro only heat on passenger side of vehicle
1) I removed all actuators and inspected all working fine
2) took reading of both heater core hoses 20 degrees difference
3) went and purchased rad flush from auto store put all of it in a small one gallon pucket took a small submersible pump that would except a garden house fitting and ten feet of hose 5/8 .I installed female hose end on one piece of five foot hose that I cut off the ten foot length I bought and then attached it to the pump and the discharge side (other end) I attached to the inlet of the heater core.
4) the last of the other five feet of 5/8 hose I used as my return that I put back into the same one gallon bucket my pump was in so that I was not wasting any of the rad flush what ever I pumped into the heater core was reclaimed and this has I would have a continuous flush happening
5)before I started the pump up I added half gallon of hot hot water to the rad flush in the bucket so it would dilute it a bit and plus offer enough liquid for pump
6)I ran the solution for 20min then shut pump off then took my supply line and switched the lines around and flushed the opposite way for another 20 mins and then shut pump off
7)YOU HAVE TO DO THIS STEP VERY IMPORTANT
Once flush was complete I took five gallons of water (HOT) Took the same pump out of the solution I made with the RAD FLUSH and put it in the hot water and flushed it clean to exhaust any chemicals I left behind and once I flushed it with clean water I switched hoses around again on the heater core and put another five gallons back through in the other direction

8)reinstall your original hoses in the proper order top up antifreeze burb system and away you go WORKS AMAZING GUYS Problems fixed and way to much heat for a small SUV!!!!!

Enjoy and hope this helps
 

·
Registered
Joined
·
2 Posts
Hey all! Been awhile but have an issue. Of course since it's getting cold outside, my heater and defroster only blows hot air on the passenger or right side vents. The left side seems to blow cold air or vent temp. air.
Any help with this problem would be great! Wife drives it and we're supposed to have a chance for freezing rain and possible snow Thursday night! So I need to figure this out QUICK!


I back flushed the heater core then installed a cooling system heater core filter on the heater core intake so far lots of heat found the filter on Ebay the seller only posts a picture of 3/4 size but he has 5/8th also hope this helps I have not had to replace the heater core
 

·
Registered
Joined
·
2 Posts
I back flushed the heater core then installed a cooling system heater core filter on the heater core intake so far lots of heat found the filter on Ebay the seller only posts a picture of 3/4 size but he has 5/8th also hope this helps I have not had to replace the heater core

I back flushed mine as well both ways and it heats like new as well.,Did you see my previous post??
 
301 - 320 of 323 Posts
Top