Dodge Nitro Forum banner

21 - 31 of 31 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #21
Ok before I head to bed, I checked cylinder 2, 4 and 6 at tdc and no valve leak, also when I removed the negative terminal on the battery while the engine was running and the light were flickering. Probably a bad rectifier causing my issue. Either way will report back in the am
 

·
Registered
Joined
·
33 Posts
Discussion Starter #22
Ok, so I just realized that cylinder 1,3 and 5 is on the driver side. I’ve been checking those the whole time. Either way I checked cylinder 2, 4 and 6 on the passenger side and there no valve leak or bottom end leak. I checked for spark in all cylinder and that’s good. I haven’t been able to check injectors. I checked all fuse and swapped relay in the fuse box.

I did notice on cylinder 4 the new spark plug that’s only days old was dark and I read online that from running rich and all the other spark plugs look normal with a little bit of white on them
 

·
Khaki Nitro Nut
Joined
·
29,467 Posts
Interesting, usually the Nitro will die if you disconnect the Neg battery terminal.
It is possible the cylinder 4 injector is leaking.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #24 (Edited)
Ok just wanted to update, I replaced the crankshaft sensor and that fixed my hard start issue I had, I just got the misfire on cylinder 2 again and finally I pulled off the valve cover all seem good.

ok I just got back from working on the car. Comparing to bank 1 cylinder, seem like I have an exhaust valve leak
 

·
Registered
Joined
·
33 Posts
Discussion Starter #25 (Edited)
ok so this is what I have tested and found out. I did a leak down test with the valve cover off and all cylinder seem to have a little bit of bottom end leak, on the tester shown here all Cylinder read from 20% to 40%, which mean its good, none of the cylinder had exhaust valve leak
38624


Now cylinder 2 had a little bit of intake valve leak until I put oil in it.

Beside the intake valve leak I found on cylinder 2, the valve and seat looks all good.
38625

38626
38627
38628
 

·
Registered
Joined
·
33 Posts
Discussion Starter #26
So I’m still confused why my car is was flooding on start up, I didn’t get a chance to check if that stopped after I replaced the crank sensor. Either way the misfire was still present and still continue to run as usual.

so I know engines that has been flooded may read low compression from the ring not making a seal in the cylinder wall, I’m wondering if that’s my issue with the crankcase leak pass the piston, also the oil don’t look normal for only being a week old. I will take pics. I may pull out cylinder 2 and 4 piston and check the rings and measure the cylinder wall.
 

·
Khaki Nitro Nut
Joined
·
29,467 Posts
Pull the EGR and clean it as well, just to eliminate it as a possible.
 

·
Registered
Joined
·
33 Posts
Discussion Starter #28
Pull the EGR and clean it as well, just to eliminate it as a possible.
I was going to replace it. One thing I noticed as well turning the engine is that the passenger side all cylinder leak pass the compression stroke and not the driver side.

I’m going to tested the fuel rail system, going to remove start ignition wire so the engine down crank, going to test ohm on injector and I have a handheld o scope to see the frequency and power to the injector also going to measure the gas from each injectoR somehow.

unless all those rings are worn? Or may be pcm doing some things. I just may replace rings anyway since passenger side is accessible
 

·
Registered
Joined
·
33 Posts
Discussion Starter #29
Ok well I’ve been having fun all day taking off the oil pan that was stuck to the gasket/aluminum shield, now I need to replace both. Either way the 4x4 don’t make it easy, I removed both motor mount and loosened the rear A frame bolt and jack the motor up from the transmission oil pan, used some wood to distribute the weight on the pan so it don’t bend.

38635


so here pic of the piston, everything look good imo. That’s cylinder 2 and I removed cylinder 4 as well and it looks good. I also checked the ring in the cylinder wall to see if there any sign of wear leaving a gap in the ring and all seem good.
38636
38637
38638
38639
38640


I’m going to replace the rings for the heck of it and going to have cylinder 2 intake valve replace and the head checked. But once it’s up and running, if I see signs of flooding on start up, going to assume it’s the pcm and replace it and have it programmed.

I’ll report back next weekend
 

·
Registered
Joined
·
33 Posts
Discussion Starter #30
Ok removed the intake valve, seat and valve looks good I can spin it on the seat with nothing looking out of the ordinary, replacing it anyway.
38641
38642
38643
 

·
Registered
Joined
·
33 Posts
Discussion Starter #31 (Edited)
Just got a good deal on a Autel 908 pro. Software was wiped. Already registered under my name and I already have a annual subscription on the way. So if this nitro need an ecm I can program it myself.
38648
 
21 - 31 of 31 Posts
Top