Dodge Nitro Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hi guys, another test here for me and the 2007 Nitro 3.7 SXT model. After putting on a new serpentine belt I was hoping I could have some trouble free motoring for a while and only think about normal things like an oil change or tire rotation in the future. However, the Nitro began running a little rough and noticeably at idle, this started to get worse and of course then the check engine light came on, checked with the OBD2 scanner and the P0302 code came up showing a misfire on cylinder 2. Ran a few basic checks myself by swapping the the ignition coil with cylinder 4 and erased the code in hope that the engine light would come back on and then show a misfire on cylinder 4, however after commuting short distances to work for a week the engine light never came back on even though it was running increasingly rough. Still no light so I plug in the ODB2 scanner and then suddenly the code P2099 pops up even though the check light still isn’t on! I have read about checking the o2 sensor but will wait until tomorrow now as it’s too damn hot here in California and would be great if any of you guys have any tips on this one as what to do here that’s cost affective and gets the Nitro running good and hopefully trouble free.
 

·
Registered
Joined
·
5,579 Posts
only the cheap copper plugs are recomended on the 3.7l, all other seem to give a misfire after a short time,
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
I took the o2 sensor off that’s supposedly giving trouble, does look like it needs replacing so I’ve ordered that and 6 spark plugs all from wholesale mopar parts so hopefully once I put them on it’ll do the job. Didn’t fancy spending on new coils just yet, especially since doesn’t appear to be any issues with them, just the plugs are only $5 each seems worth changing those.
Will keep the thread updated but appreciate any other experiences with this.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #4 ·
a little update on this one, replaced spark plugs and o2 sensor and today at around 50mph it started to ‘splutter’ and the check engine light flashed on and off a few times, was running badly after that and pretty much anytime accelerating it would do the same, at idle it jolts away before moving, running terribly and reading code P0302 again detecting a misfire on cylinder 2.
I’m reluctant to replace the coil as when testing the coils I didn’t find any problem. I found an old thread from 2015 on here regarding P0302 and didn’t like what I was reading. Has anyone had any experience with this at all please? I think my wife will kill me if I tell her about yet another problem with the car so I’m hoping to sort it asap.
 
1 - 4 of 4 Posts
Top