Dodge Nitro Forum banner
21 - 36 of 36 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #22 ·
the reason i asked about the Amp is because the wiring is different, i can take a look at the wiring diagram and see what might help diagnose this,
do you have any other electrical issues "any" ?
Other electrical fault I have is the passenger rear door remote opening and locking and cabin light sometimes it doesnt come on with driver's door open. not sure if there can be a reasonable link with the radio
 

·
Registered
Joined
·
5,418 Posts
i don't think those electrical issues are linked to the radio, i'll take a look at the wiring diagrams again,
this type of radio only has 2 faults that i am aware of :
1st is no sound
2nd is stuck CD
because both radios are giving the same fault i would assume they are both ok,
once you have plugged in the connector at the back of the radio, are there any spare connectors or wires left , like maybe the vehicle originaly came with a different radio ?,
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #24 ·
i don't think those electrical issues are linked to the radio, i'll take a look at the wiring diagrams again,
this type of radio only has 2 faults that i am aware of :
1st is no sound
2nd is stuck CD
because both radios are giving the same fault i would assume they are both ok,
once you have plugged in the connector at the back of the radio, are there any spare connectors or wires left , like maybe the vehicle originaly came with a different radio ?,
T

Thanks for the response. I actually agree with you that both radios should be ok and that the submitted faults should not be related to the radio fault. I connected it back on yesterday after checking all 3 cabling sockets and and arial cable are connected to the back of the radio..

I am however, noticing one thing here. I didn't test the cables to the small middle socket at the back of the radio. What are these cables for?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #25 ·
T

Thanks for the response. I actually agree with you that both radios should be ok and that the submitted faults should not be related to the radio fault. I connected it back on yesterday after checking all 3 cabling sockets and and arial cable are connected to the back of the radio..

I am however, noticing one thing here. I didn't test the cables to the small middle socket at the back of the radio. What are these cables for?
 

·
Registered
Joined
·
5,418 Posts
C1 is for the hand free option, looking at the wiring diagram can't see any reason why this would stop the radio working,
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #31 ·
C1 is for the hand free option, looking at the wiring diagram can't see any reason why this would stop the radio working,
Thanks once again. It looks like wiring is not the issue, radios are also possibly not the issue, its an interesting puzzle. Thanks for the assistance so. We have certainly eliminated a lot of issues. yet to identify successfully the issue though.
 

·
Registered
Joined
·
5,418 Posts
the other day i tried to get my radio to come up with the same error message as yours, but it didn't, with the radio off and the ignition off the only thing i can do is eject and load CD's ,
 

·
Registered
Joined
·
5,418 Posts
misunderstood i think,
my radio works fine, with the radio and ignition OFF, i push all the buttons on the radio nothing happens, no error massages nothing, only if i press the cd eject or load buttons then the radio powers on so i can eject/load a cd (won't let you me play music), the ignition has to be switched on for the radio to power on,
 

·
Registered
Joined
·
5,418 Posts
did you check the CAN resistance
here is a link to a CAN BUS explanation,
 
21 - 36 of 36 Posts
Top