Dodge Nitro Forum banner
21 - 40 of 44 Posts

·
Registered
Joined
·
609 Posts
Discussion Starter · #23 ·
Could not resist could you? I love the new look and it starts up faster and switches source faster too.
 

·
The Univalent Radical
Joined
·
7,287 Posts
Could not resist could you? I love the new look and it starts up faster and switches source faster too.
Well, they did offer to try and fix my old one - a "force start", maybe. But the more that I looked into this, I was at the point that my hardware was too old to accept the newest software. They offered me a good deal - not a great deal. But, I am OK with this. I will put off the sub installation for a while, until I make up the difference! Let's see; what can I live without for a while? LOL

I'll post some pictures to see if the RHB and RBZ share the same graphics, without the Navigation.

:cool:
 

·
The Univalent Radical
Joined
·
7,287 Posts
New radio arrived today: PN 05091327AE, v50.00.07, Dealer Take-out of a 2014 Chrysler Town and Country. Graphics are the same as your RHB. Added benefit: Sirius Trial thru 8/14. My subscription on the old RBZ expires this month, so I have a small credit coming!

Funny how things work out sometimes!

:cool:
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #26 ·
Sweet, the graphics I think are sharper also. That's great you got Sirius for almost a year too.
 

·
The Univalent Radical
Joined
·
7,287 Posts
One issue with the installation. The newer versions say Antitheft on the Lower Left Corner of the radio face plate. On the initial start, there is supposed to be a screen where you enter a 4-digit code. I have the code, but there were no instructions on how to get the screen to appear. I thought maybe pushing a combination of the hard keys. No luck.

So, I called OEM, to see if there was some kind of "trick" to get the screen to appear. The tech told me that sometimes this happens: no automatic screen on initial start up. So, I had to reset the TIPM. He told me to wait 1/2 hour. Reconnected the negative terminal, started the Truck, turned on the Radio and like magic the screen appeared! I never would have thought of this.

I even called my Dealer to see if there was a "trick". Of course, they told me to "bring it in". $$$$$$$$$$$$$$ :loser1:

All is well. Graphics are awesome.

:cool:
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #28 ·
I also notice on my RHB that it starts up much quicker to a usable radio after the update. I have completely removed the lockpick and have not had anymore issues too. I'm going to sell the lockpick too.
 

·
The Univalent Radical
Joined
·
7,287 Posts
If you sell the Lockpick, how will your back up camera work? Since I received my replacement, I have had no issues with the Lockpick. No issues with the new radio.

Radio does seem to work "faster", like you said, and I like the fact that there is not that much difference between the day and night screen brightness.

:cool:
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #30 ·
If you sell the Lockpick, how will your back up camera work? Since I received my replacement, I have had no issues with the Lockpick. No issues with the new radio.

Radio does seem to work "faster", like you said, and I like the fact that there is not that much difference between the day and night screen brightness.

:cool:
Our camera has been disconnected since the last issue with the lockpick. I might see if the dealer can add it to the build if not oh well.
 

·
The Univalent Radical
Joined
·
7,287 Posts
Does the RHB have the jack for a camera? I know that one of the migigs does; maybe the 730N.

I forgot to look at the back of mine, and I'm not taking it out again! LOL

:cool:
 

·
Registered
Joined
·
147 Posts
I know my Nitro is a 2007, but it did not come with a MyGIG. I got one from OEM Auto Parts (I am guessing the same place as you dhh3). It is a RBZ 4678 (I believe a media 430, but I can't find it again since they changed the site). I got it back in June.

Currently, it has the Application as 8.5.1. I am not sure if I just got one with an old version, or if it has something to do with it being in a 2007 Nitro. Any thoughts?

I have shot off an email to OEM Auto Parts asking about this, just waiting to hear back.

Got to love the Wayback Machine :woohoo:

http://web.archive.org/web/20130503...com/usacan-high-speed-rbz-4678-30gb-p-33.html

That should be the one I ordered.
 

·
The Univalent Radical
Joined
·
7,287 Posts
Yours' is the old hardware version, like my old one was. There is an update for v10. That was the update that I was trying to do, when my radio froze. Since I never got it installed, I do not know what the update does! OEM sent me the disc, so this would be the only and final update for the older version hardware. Since you are a customer, they will send you the update disc for free. If you go this route, I will tell you how to do the installation, but I will not guarantee the outcome! LOL

They are all considered Media Center 430's.

Just as a FYI, the newer hardware versions with v50 will work in your Nitro. OEM may take your old one as a trade.

:cool:
 

·
Registered
Joined
·
147 Posts
They are going to send me the CD as well.

I am not sure if they would take it on trade, at least not an equal trade. I also didn't get the extended warranty, so the warranty on it is up.
 

·
The Univalent Radical
Joined
·
7,287 Posts
They are going to send me the CD as well.

I am not sure if they would take it on trade, at least not an equal trade. I also didn't get the extended warranty, so the warranty on it is up.
No, it would not be an equal trade. I was told that they only have the newer hardware versions, updated to v50. Mine is brand new, dealer take-out of a 2014 Chrysler T&C. I got lucky.

You can PM me when you receive the disc and they did not include instructions. I sent my disc back to them to see if it was corrupt.

:cool:
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #36 ·
Does the RHB have the jack for a camera? I know that one of the migigs does; maybe the 730N.

I forgot to look at the back of mine, and I'm not taking it out again! LOL

:cool:
No camera inputs so to speak. All Mygig radios use the white plug for VES and rearview cameras. So it's easy if the dealer can add it to the vin and update the computer. If it takes in the computer then it will be active in the radio menus. There have been many reports on the charger forums of adding a camera from a Cherokee and updating the vin. The older chargers were not available with a backup camera.
 

·
Registered
Joined
·
147 Posts
I guess I got a choice to make. Upgrade the current one I have, or trade it in for $199 plus return shipping.
 

·
Registered
Joined
·
147 Posts
No camera inputs so to speak. All Mygig radios use the white plug for VES and rearview cameras. So it's easy if the dealer can add it to the vin and update the computer. If it takes in the computer then it will be active in the radio menus. There have been many reports on the charger forums of adding a camera from a Cherokee and updating the vin. The older chargers were not available with a backup camera.
Any chance a Backup Camera would work on an 07 Nitro? Right now, I have the aftermarket camera and it would be nice to get it off my dash (the arm is kind of broken, so it doesn't like to stay in one spot). I know I can get a lockpick and do it that way, but looking at all possible ideas.
 

·
Registered
Joined
·
609 Posts
Discussion Starter · #39 ·
Any chance a Backup Camera would work on an 07 Nitro? Right now, I have the aftermarket camera and it would be nice to get it off my dash (the arm is kind of broken, so it doesn't like to stay in one spot). I know I can get a lockpick and do it that way, but looking at all possible ideas.
Right now the only way is by Lockpick. I have not asked the dealer about adding it to the vin build.
 
21 - 40 of 44 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top