Dodge Nitro Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I installed an aftermarket stereo 2 years ago without problems. Then, a few months ago the front right speaker would start to squeal to dog whistle proportions even when I shut it off! I assumed it was the speakers, so I replaced all 4. It still happened. So I figured it was the stereo so I replaced it with a CarPlay model and I added an amp and dual sub while I was at it. Lol
The problem was still there! Ugh.
I now was too deep to give up, so I cut the front left speaker wires from the harness and ran new wires from the head unit thru the dash and thru the door raceway to the speaker.
Problem solved!! Unfortunately it blew the new speaker, but I put in one of the old ones (for now) and now I have one boss system that sounds amazing.
So: if you are having a similar issue it just may be the factory speaker wires causing the fault.
I feel very accomplished right now.
The coronavirus gave me some unexpected vacation time to spend chasing my problem.
I really hope my experience can help someone out there. I can’t be the only one!
Stay virus free my Nitro brothers and sisters!
Mic drop.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
S
I installed an aftermarket stereo 2 years ago without problems. Then, a few months ago the front right speaker would start to squeal to dog whistle proportions even when I shut it off! I assumed it was the speakers, so I replaced all 4. It still happened. So I figured it was the stereo so I replaced it with a CarPlay model and I added an amp and dual sub while I was at it. Lol
The problem was still there! Ugh.
I now was too deep to give up, so I cut the front left speaker wires from the harness and ran new wires from the head unit thru the dash and thru the door raceway to the speaker.
Problem solved!! Unfortunately it blew the new speaker, but I put in one of the old ones (for now) and now I have one boss system that sounds amazing.
So: if you are having a similar issue it just may be the factory speaker wires causing the fault.
I feel very accomplished right now.
The coronavirus gave me some unexpected vacation time to spend chasing my problem.
I really hope my experience can help someone out there. I can’t be the only one!
Stay virus free my Nitro brothers and sisters!
Mic drop.
Sorry- it was the front LEFT speaker.
 

·
Khaki Nitro Nut
Joined
·
29,467 Posts
Thanks for the tip!
 
1 - 3 of 3 Posts
Top