Dodge Nitro Forum banner
1 - 13 of 13 Posts
G

·
Discussion Starter · #1 ·
In the mornings when I'm leaving for work the controls don't work. Well, I thought maybe it's because they are cold and it'll have to warm up. I have about a 45 min drive in the mornings and about 15 miles down the road they start working again..yeah I know crazy...but now I'm starting to wonder if maybe it's a wiring problem. Beacuse now crusie control doesn't work. Anyone else having this problem? I called the dealership this morning and we have an appointment for Saturday....so I guess I'll see what they say then..:confused:
 

·
NITROHOLIC™
Joined
·
1,794 Posts
Very weird...Im in texas and it only gets down to mid 40s here and I havent experienced any problems..I probably should check to make sure my cruise control is working though..Audio controls and steering controls havent failed me once...Defintely take it to the dealer theres obivously a problem!
 

·
Registered
Joined
·
421 Posts
I am located up in Canada and we have already had a few days/nights below 0 C (32 F) with absolutely no issues. Same audio controls I had on my 2003 Dodge Ram and I had no issues then either. Must be something specific to your Nitro:(
 

·
Registered
Joined
·
790 Posts
No problems with either here. And we've seen plenty of temps below freezing. The Nitro has seen 4" of snow piled on it. And towed the ATV trailer thru 7" or 8", 100 miles & back.
SLT, 3.7, AT, 4x4, build date is 12/06.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top