Dodge Nitro Forum banner

Share your experience with your Automatic Transmission


  • Total voters
    73
  • Poll closed .
301 - 320 of 353 Posts

·
Khaki Nitro Nut
Joined
·
29,326 Posts
Welcome to the forum Vansan.

When you have a chance, head over to the Newbie Section and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.

There is a temperature valve in the transmission lines that go to the cooler. Once that opens up, it is possible you do not have enough fluid for the transmission to operate correctly.
As Fastcompany said; You will need to get the leak fixed. Then have the fluid checked and filled by a garage with the right equipment to do it.
 

·
Registered
Joined
·
19 Posts
Thank you for your help. I can give couple more information. The car is still drivable. When i tried a car again after four hours. My car was again Okey and transmission been working. All speed were without troubles. That's very weird. I really do not understand. Is that possible there is problem with fluid ? I was getting there different fluid to in because like i said i have leak in transmission cooler/line. I always added just for sure. When it starts fluid getting warm so i think something must be there wrong. Because when is a car cold everything is Okey and without problems. Is that normal? I really do not understand ?
 

·
Registered
Joined
·
322 Posts
And trannies can be hard to diag. That's one part on a car I'm not fond of. Could be a front pump going out after its hot could be seals getting blown past. I can watch different parameters on a scan tool to point me in the right direction. Sometimes it's simple like a solenoid on a valve body....or like my nitro the dealer just reused my trans case as everything was bad. In my experience most problems happen with them as they get hot so that's not uncommon. Very hard to diag over the net though. Let us know what your garage tells you.
 

·
Registered
Joined
·
19 Posts
You right i will do just make sure and make safe for my car. I gonna wait for thursday and then i'll see. I hope all it will be okey. I really like it this car.
 

·
Registered
Joined
·
19 Posts
I've been today in garage. They told me few words on my transmission but nothing seriously. Probably i have to change garage and try someone else. I need to know what exactly is there wrong. They fixed me today transmission lines/cooler. I thought that gonna be everything Okey but not. After 5 miles when i was getting home from garage the transmission cooler started again leak but a lot. I'm little bit getting mad because this is not possible. I have to visit again tomorrow a garage and i'll see. I really do not understand.
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
I hope a garage can find you problem.
 

·
Registered
Joined
·
19 Posts
I've been today again with my car in the garage. The problem with leak was fixed. More makes me different problem with transmission. They do not know find problem. When i drive my car it must be cold so transmission works really great but when is getting fluid in there warm it starts to do really bad things. When i always leave the highway and stop at red light then i cannot get more speed when i driving. My driving is 30mph at 3000rpm it cannot give me speed2. Is here someone who had the same problem as me? I'm really confused and cannot find the problem there. Is that symptom transmission failure? It's very weird and crazy. Thank you for help.
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
Your Nitro is going into "Limp home" mode.
It can be caused by many different things and may not be related to your transmission at all. Did the garage get any codes when checking the Nitro?
 

·
Registered
Joined
·
19 Posts
I left my car there in the garage. Check engine came up in moment when transmission started to do bad things. They did not say me nothing yet. They told me no leaks and nothing bad there. I said please can you make a test drive and check my transmission problem. "Limp home mode" i've heard first time. They checked me all fluids. Everything is Okey and ready to go. It's very weird and i'm hoping it's gonna be okey very soon. I do not want to put new transmission.
 

·
Registered
Joined
·
19 Posts
We've tried reset all codes and drive again it goes back. For 5 miles it came up check engine light. Codes is just P0846. What can you recommend me ? Put new transmission or try to fix ? I have on it 135xxx miles thank you
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
P0846 = Transmission fluid pressure (TFP) sensor B - range/performance problem. Possible causes; Wiring, poor connection, TFP sensor, ECM/PCM/TCM
P0871 = Transmission fluid pressure (TFP) sensor C - range/performance problem. Possible causes; Wiring, poor connection, TFP sensor, ECM/PCM/TCM

This is not something we can really help with. A dealer will have to run computer tests on your transmission to figure out exactly what is wrong.
:(
 

·
Registered
Joined
·
19 Posts
Someone wrote that tried to replace two sensors and was all Okey but i'm not sure if this good way to Fix.
Like you said maybe i have to bring car a Dealership. I gonna try as soon as possible. But i'm still thinking put new transmission and Fix all problems. The dealer wants a lot money almost for nothing.
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
Less $ would be a new Valve Body $350 + install. It includes new sensors, solenoids, and a lot more.
A Valve Body would only work if the rest of the transmission is OK. New transmission is a lot of $.
Problem can also be low fluid, to much fluid, or bad wires.
If it were me I'd have a dealer diagnosis to know what is really wrong.
 

·
Registered
Joined
·
19 Posts
Do you know how much they will want for transmission test around ? I never been in a dealer. I have no idea how is going there prices. I'm still trying find best way. My friend told and he found transmission for $500 with 95,000miles on it and he said with labor around 450-500$ plus fluid. I'm still thinking about it. Together will be around $1000 is not so bad. Or maybe as you said buy new valve body? But i found valve body the cheapest for $450..
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
My local Dodge dealer charges $90 Per hour. I do not know how long it would take.
Valve body; Search 5078327AA here. https://moparonlineparts.com/mop-parts/#parts
Or give message to Benny, (He is our Dodge parts vendor) he can look it up and price it for you. Click here. He will need your VIN#.
Great guy to deal with.
 

·
Registered
Joined
·
19 Posts
thank you a lot for your help but i would like to ask for last time. I've seen the same problem but it was dodge journey 2011 it had p0846 and he wrote there that just replacement Solenoid pack and car runs and shift as before. What do you think is it good an idea and try to do? Maybe should be help me Fix this problem. The Solenoid pack is inside transmission or somewhere out?
 

·
Khaki Nitro Nut
Joined
·
29,326 Posts
You can try a solenoid pack replacement.
Again, without a dealer diagnosis, I am not sure this will solve your problem...
The solenoid pack is inside the transmission.

The solenoid pack is included with the Valve body # I posted earlier.
 
301 - 320 of 353 Posts
Top