Dodge Nitro Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, first time posting on here and it’s a relief to see so many people active on the nitro forum. I have a 2010 nitro and have been hearing this clicking noise coming from the wheel well on the front left side. I took to google and found people talking about tie rods, suspension, and cv axle replacement, so I’ve come here to get a second hand look to see if y’all can help pinpoint the problem for me. I propped up the car on both sides and rotated/turned the wheel to see if I could find where the sound was coming from but nothing I didn’t hear the clicking sound once. As I dropped the jacks and the weight returned I heard one single click that sounded like the issue I’d been having. I attached some pictures and videos in hopes that helps. Seems to only happen with turns while weight is applied. Once again thanks for your time guys and have a great day!
39751
39752
39753


Here’s the video of the sound while driving.
 

·
Registered
2011 Dodge Nitro Heat 3.7L
Joined
·
1,278 Posts
Bad spot in the wheel bearing maybe :unsure:
 

·
Registered
2008, 3.7 SLT 4x4, 2.5 "lift
Joined
·
17 Posts
Your sway bar links. Tighten them. (This happens on speed bumps etc?)

After watching your video. I am certain it is your links... like 70%... I just drove home day before yesterday with this after a trail, I fixed it with two 18" wrenches.

If that doesn't work. Your upper ball joint maybe. ... which is actually the whole control arm lmao.

This is very recent to me, I just swallowed all these problems. Hope my experience helps you.
 

·
I work so I can... SQUIRREL!
Joined
·
2,624 Posts

Good to have you here. Enjoy the forum!
BTW... Post a pic of your Nitro when you can.
 

·
Registered
07’ SLT 4x4 Lifted, 3.7 auto
Joined
·
778 Posts
def not CV joints....atleast in my opinion. my guess is the sway bar links as well....take it for an alignment....a good shop wont align it and tell you what is messed up and in need of replacement before they can align it....then tell them ok and go home and DIY
 

·
Registered
2008, 3.7 SLT 4x4, 2.5 "lift
Joined
·
17 Posts
def not CV joints....atleast in my opinion. my guess is the sway bar links as well....take it for an alignment....a good shop wont align it and tell you what is messed up and in need of replacement before they can align it....then tell them ok and go home and DIY
Yep. 2 18" wrenches. ..

An alignment is so over rated.(not that you need one.. but if you ever do).. All you need is a tape measure and YouTube. ;)

Also,looking at your pictures... your links are loose AF.
 

·
Registered
Joined
·
5,223 Posts
maybe its just the way the pics have been taken, But is there a split in the small rubber boot on the top ball joint ?.
 

·
Registered
2008, 3.7 SLT 4x4, 2.5 "lift
Joined
·
17 Posts
maybe its just the way the pics have been taken, But is there a split in the small rubber boot on the top ball joint ?.
Mine is ripped. It doesn't make that noise... hehe.... New control arms on the way :/ (bootable ones).
 
1 - 8 of 8 Posts
Top