Dodge Nitro Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 07 Nitro won't start . It Acts as if the battery is dead. I jump it is starts. It idles rough but it starts. I checked the battery voltage output and it indicates it is fully charged. I turn it off then try without a jump and still the same loud noise.
Okay so the battery is no good right???
No!
I tried 3 different batteries with the same result. It Starts with jump. The battery is fully charged but the truck won't turn over without a jump.
Help me!
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Welcome to the forum @ItsSarah. When you have a chance, head over to the Newbie Section (<click this) and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.
Sounds like your battery clamps are all cruded up. Thus a jump works but it is not getting juice from the installed battery.
 
  • Like
Reactions: JPthekid

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Welcome to the forum @ItsSarah. When you have a chance, head over to the Newbie Section (<click this) and say "Hi".
Tell us a little about yourself and your ride.
That way we can welcome you all proper like.
Sounds like your battery clamps are all cruded up. Thus a jump works but it is not getting juice from the installed battery.
Thank you for your response. I cleaned the clamps And still the same results. . I drive 07 dodge nirto SLT 2wd I bought it new.. I let my brother drive the car for a year and just got it back last week. The poor car was completely ran into the ground and now im left with all these problems.. it runs really rough and won't idle.
I just replaced the TIPM because of malfunction in the electrical system. It fixed some things but not all.
 

·
Registered
2011 Dodge Nitro Heat 3.7L
Joined
·
1,217 Posts
Thank you for your response. I cleaned the clamps And still the same results. . I drive 07 dodge nirto SLT 2wd I bought it new.. I let my brother drive the car for a year and just got it back last week. The poor car was completely ran into the ground and now im left with all these problems.. it runs really rough and won't idle.
I just replaced the TIPM because of malfunction in the electrical system. It fixed some things but not all.
Did you have the TIPM programmed to the Nitro? And was it the correct TIPM for your Nitro?
 

·
Registered
Joined
·
10 Posts
I've thought of your problem for a bit and I have a couple of thoughts.

Your Nitro won't start with its own battery. But it'll start with a jump and idle rough. You've tried new batteries. So, I'm gonna go on the thinking that you have a 100% healthy battery. It sounds like the basic problem is that the battery isn't able to deliver enough amps to the starter to crank the motor.

Possibility #1: There is something internal to the engine that is resisting turning over to the point where its battery all by itself can't crank the engine. This is caused by really bad stuff and I hope its not this one.

Possibility #2: The path for the heavy cranking amps has become disrupted. This is caused by a broken battery cable, possibly at the engine block end.

My 07 has a couple lighter wires from the negative terminal going to the body and a couple other things. The heavy gauge cable should go to the engine block. I just don't have my Nitro handy at the moment to see where my cable is routed. Once it's started, my alternator puts out about 40 amps until the battery is charged, then it drops to about 10. Those lighter weight wires can handle that. But, they can't handle heavy cranking amps.

I'm gonna assume that you are jumping from another vehicle and that you are using recommended practice by connecting the negative clamp to something on the engine of your Nitro and not the negative battery terminal. With that, I would suggest taking your jumper cable, with the negative side, connect one end to the negative terminal on your Nitro's battery, the other end to the engine. No need to connect the positive side to anything. See if it starts and runs.
 

·
Khaki Nitro Nut
07Lifted,4X4,6sp-man,3.7L
Joined
·
30,638 Posts
Also check the ground strap on the firewall going to the engine block/trany. Passenger side.
 
1 - 6 of 6 Posts
Top