Dodge Nitro Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
Hello all,
I am a newbie and I love my new Nitro SLT. I love it but I would like to share with you a problem potentially dangerous.
When driving on highways for more than 1 hour and at temperatures below -10 celcius...it is possible for the vehicule to loose suddenly power. It happened to me 5 times. Went to the dealer and had an electronic module (inside the air intake) ordered hopefully to correct this problem. Since this is a company car, we are about 5 or 6 guys that have experimented the same problem. Dealer will now investigate new week (feb 07th) and I will let you know the results.
 

·
Registered
Joined
·
421 Posts
dpelletier,

Do have any updates on this issue? I think I have had the same issue. I loose power and it will only sit at idle. I have been told the system senses an error and shuts off the ETC (Electronic Throttle Control). I have had mine towed once already and they replaced some sensors.

Let me know if this is the same and how it is going for you
 

·
Registered
Joined
·
2,255 Posts
it happened to me but all the dummy lights turned on and shut off, I have my radar pluged in to the socket on the dash and that shut off as well. I was doing 70 mph on the highway and the temp was 12 deg.
The power outlet on the dash is fed power directly from the TIPM. The interesting thing here is it was a momentary loss of power. Sounds again like either poor connections at the TIPM or actually a faulty module (TIPM).
 
G

·
Discussion Starter · #5 ·
Hi Jaerho-Nitro, most probably Chrysler does not have a clue yet of what is going on. My dealer refused to replace the sensor but they reprogrammed the module (the ETC I guess). All the elements needed to reproduce the problem did not happened again but I can tell you that each time it occured (5 times already) the idle is very very unstable. It did happened to other people within my company, so I am sure I am not dreaming.
 

·
Registered
Joined
·
12 Posts
My idle has also been a little unstable and I have had my truck die at low speed in about 40f so I am concerned that this might be a bigger problem.
dealler said my electronic throttle control was faulted and they reprogrammed same

allen
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top